Ask Your Question
0

How to disable "Scroll Lock" feature in Calc

asked 2017-04-04 11:34:34 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

After updating LibreOffice from 4.3.2 to 5.3.0.3 version - i'm got a trouble with "scroll lock" key feature enabled, because this key LED indicator on keyboard ("scroll lock" key is not pressing... it remapped on "ctrl+shift" combo for language switch) is using for indication language state (default indicator in Debian for language). So when i need to move to another cell with "scroll lock" indicator light on - i got only scrolling window and this is big trouble for me. Because i'm usual writing at my native language (not in english) and always need to switch on english language (scroll lock indicator light off) for move to another cell, otherwise i'll just scrolling.

I mean, how to disable this https://ask.libreoffice.org/en/questi... feature in LibreOffice Calc, via config files or via "Tools" - "Preferences" ? Using "find" for "scroll lock" in manual - found nothing needed.

Disable indication on scroll lock for language switching - is not solution. P.S. sorry for my english, it's not my native language.

edit retag flag offensive close merge delete

Comments

Please try resetting the user profile, sometimes solves strange issues. https://wiki.documentfoundation.org/U... Usually it's enough renaming/deleting the file "user/registrymodifications.xcu", it affects all the options in Menu/Tools/Options, and the files "user/basic/dialog.xlc" and "scrip.xlc" are overwritten, additionally custom colors in "user/config/standard.soc" are lost.

m.a.riosv gravatar imagem.a.riosv ( 2017-04-04 23:52:45 +0200 )edit

Thanks for response, but this action with deleting registrymodifications.xcu in user folder - did not help.

lester434 gravatar imagelester434 ( 2017-04-08 16:08:31 +0200 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2017-06-18 12:00:20 +0200

geekobi gravatar image

updated 2017-06-18 12:02:57 +0200

Hi,
I got the same problem.
I unlocked the "scroll lock" behaviour (there is generally a toggle key "scroll lock" in the keyboard to do that),
and the behaviour of calc went back to normal
(note : it is the same behaviour with Microsoft-Excel).

edit flag offensive delete link more
0

answered 2017-04-24 06:55:10 +0200

That's feature enabled in 5.3 with https://bugs.documentfoundation.org/s... So - downgrade to 5.2.* and wait for next versions, may be that will fix later.

edit flag offensive delete link more

Comments

It will not fix it, unless someone at least files a bug at Bugzilla. I haven't found one, so I can only say that call for passive wait is harmful. Please act and inform developers about your needs, instead of "wait for next versions, may be that will fix later".

Mike Kaganski gravatar imageMike Kaganski ( 2017-04-24 07:55:11 +0200 )edit
0

answered 2017-04-24 07:35:52 +0200

Mike Kaganski gravatar image

updated 2017-04-24 07:43:31 +0200

http://forum.ubuntu.ru/index.php?topi...

On that Russian forum topic about a problem in xfce 4.8 updated to xfce 4.10 on xubuntu 12.04, where changing keyboard layout started to turn on Scroll Lock, the solution was:

sudo gedit /etc/default/keyboard -> find XKBOPTIONS="grp:alt_shift_toggle,grp_led:scroll" -> remove grp_led:scroll and reboot.

(Disclaimer: I see that OP mentioned that "Disable indication on scroll lock for language switching - is not solution". I only post this here for someone who might find this topic and have different restrictions.)

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2017-04-04 11:34:34 +0200

Seen: 267 times

Last updated: Jun 18