Ask Your Question

How to disable "Scroll Lock" feature in Calc

asked 2017-04-04 11:34:34 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

After updating LibreOffice from 4.3.2 to version - i'm got a trouble with "scroll lock" key feature enabled, because this key LED indicator on keyboard ("scroll lock" key is not pressing... it remapped on "ctrl+shift" combo for language switch) is using for indication language state (default indicator in Debian for language). So when i need to move to another cell with "scroll lock" indicator light on - i got only scrolling window and this is big trouble for me. Because i'm usual writing at my native language (not in english) and always need to switch on english language (scroll lock indicator light off) for move to another cell, otherwise i'll just scrolling.

I mean, how to disable this feature in LibreOffice Calc, via config files or via "Tools" - "Preferences" ? Using "find" for "scroll lock" in manual - found nothing needed.

Disable indication on scroll lock for language switching - is not solution. P.S. sorry for my english, it's not my native language.

edit retag flag offensive close merge delete


Please try resetting the user profile, sometimes solves strange issues. Usually it's enough renaming/deleting the file "user/registrymodifications.xcu", it affects all the options in Menu/Tools/Options, and the files "user/basic/dialog.xlc" and "scrip.xlc" are overwritten, additionally custom colors in "user/config/standard.soc" are lost.

m.a.riosv gravatar imagem.a.riosv ( 2017-04-04 23:52:45 +0200 )edit

Thanks for response, but this action with deleting registrymodifications.xcu in user folder - did not help.

lester434 gravatar imagelester434 ( 2017-04-08 16:08:31 +0200 )edit

Just experienced the same problem with 5.3.2 on Xubuntu (just updated recently, so probably due to new version). I use Alt+Shift to change language setting and apparently this is mapped by LO to switch on "scroll lock". There is a "scroll lock" button on my ThinkPad X201 (never realised before) but this is apparently out of function. My temporary solution is to stick to one language in LO until bug is fixed.

samuelk gravatar imagesamuelk ( 2017-07-26 18:09:49 +0200 )edit

Hello there. The same problem, but I'm using KDE and disabling "System Settings - Input Devices - Keyboard - Advanced - Use keyboard LED to show alternative layout - Scroll Lock" did help.

ViEm77 gravatar imageViEm77 ( 2017-08-14 09:19:07 +0200 )edit

5 Answers

Sort by » oldest newest most voted

answered 2017-04-24 07:35:52 +0200

updated 2017-04-24 07:43:31 +0200

On that Russian forum topic about a problem in xfce 4.8 updated to xfce 4.10 on xubuntu 12.04, where changing keyboard layout started to turn on Scroll Lock, the solution was:

sudo gedit /etc/default/keyboard -> find XKBOPTIONS="grp:alt_shift_toggle,grp_led:scroll" -> remove grp_led:scroll and reboot.

(Disclaimer: I see that OP mentioned that "Disable indication on scroll lock for language switching - is not solution". I only post this here for someone who might find this topic and have different restrictions.)

edit flag offensive delete link more


The RFE to make this configurable is tdf#112876. This is an easy hack for anyone who wants to implement that, which means the problem is evaluated and found to be easy to fix; there are code pointers in the bug; and we would provide necessary help (for specific development-related questions) to whoever decides to work on this.

Mike Kaganski gravatar imageMike Kaganski ( 2020-07-27 10:03:44 +0200 )edit

answered 2017-06-18 12:00:20 +0200

geekobi gravatar image

updated 2017-06-18 12:02:57 +0200

I got the same problem.
I unlocked the "scroll lock" behaviour (there is generally a toggle key "scroll lock" in the keyboard to do that),
and the behaviour of calc went back to normal
(note : it is the same behaviour with Microsoft-Excel).

edit flag offensive delete link more

answered 2018-05-17 20:29:26 +0200

chda gravatar image

As fast hack you can use this patch to libreoffice source code:

--- libreoffice-   2018-01-30 20:22:07.000000000 +0300
+++ patched/sc/source/ui/view/cellsh4.cxx       2018-05-17 19:54:21.233576020 +0300
@@ -129,8 +129,8 @@
     // scrolling the grid.
     bool bScrollLock = false;
     KeyIndicatorState eState = GetFrameWin()->GetIndicatorState();
-    if (eState & KeyIndicatorState::SCROLLLOCK)
-        bScrollLock = true;
+    //if (eState & KeyIndicatorState::SCROLLLOCK)
+    //    bScrollLock = true;

     //OS: once for all should do, however!

Tested on libreoffice- However this patch may work on another affected versions.

Gentoo users can put this code to /etc/portage/patches/app-text/libreoffice- and execute

emerge =libreoffice-
edit flag offensive delete link more

answered 2020-07-27 00:00:44 +0200

For those who like myself activated the scroll lock function with a keyboard shortcut without realizing it and do not have a scroll lock button on their keyboards, I found the tips in this wiki page to be helpful and I was able to resolve my problem using one of the suggested keyboard shortcuts for turning off the scroll lock function:

edit flag offensive delete link more

answered 2017-04-24 06:55:10 +0200

That's feature enabled in 5.3 with So - downgrade to 5.2.* and wait for next versions, may be that will fix later.

edit flag offensive delete link more


It will not fix it, unless someone at least files a bug at Bugzilla. I haven't found one, so I can only say that call for passive wait is harmful. Please act and inform developers about your needs, instead of "wait for next versions, may be that will fix later".

Mike Kaganski gravatar imageMike Kaganski ( 2017-04-24 07:55:11 +0200 )edit
Login/Signup to Answer

Question Tools



Asked: 2017-04-04 11:34:34 +0200

Seen: 9,335 times

Last updated: Jul 27 '20