Ask Your Question
0

"the maximum number of rows has been exceeded" [closed]

asked 2012-12-19 21:13:12 +0200

anonymous user

Anonymous

updated 2015-09-07 10:54:50 +0200

Alex Kemp gravatar image

Hi, I have attempted to open a 1232 line CSV file of 493KB in LibreCalc, and get an error message "The maximum number of rows has been exceeded. Excess rows were not imported!"

This is not a huge CSV, size or line-wise. Why has this occurred? Excel can handle much larger files. I thought Calc could handle around 65K lines.

LibreOffice 3, 3.4.5.2, build ID 350m1(build:2) running on LinuxMint 13

Thanks,

Greg

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-21 14:52:00.308481

Comments

I'll try to be more specific, but what do you need to know?

A not very large CSV file is simply choked LO at about line 1060 . It came out of a database dump.

marietta_greg gravatar imagemarietta_greg ( 2012-12-19 23:59:26 +0200 )edit

Oh! OK, I didn't understand what I was supposed to do with the (for f in seq 1 63000; do echo > "foobar,$f"; done) > foobar.csv, and that you suspected a corrupt source CSV. My CSV looks OK in a text editor. Nevertheless, I dumpted a fresh one, and it imported fine. So it apparently was a

marietta_greg gravatar imagemarietta_greg ( 2012-12-20 04:23:16 +0200 )edit

problem with the CSV. If your code was to produce a 63k line text file, it did not, or I used it incorrectly. I simply pasted it into my console and executed. Only produced a 0 bype file and three 1 byte files. Suggestion? Thanks for your responses

marietta_greg gravatar imagemarietta_greg ( 2012-12-20 04:25:37 +0200 )edit
1

May be there are too many separators in import (tab, comma, semicolon, space, ...) Often the presence of "space" cause such problems

Timon gravatar imageTimon ( 2012-12-20 05:43:32 +0200 )edit

5 Answers

Sort by » oldest newest most voted
0

answered 2012-12-23 14:36:38 +0200

qubit gravatar image

@marietta_greg -- Here's similar code that works for me:

    for f in `seq 1 63000`; do echo "foo,$f" >> foobar.csv; done
edit flag offensive delete link more

Comments

Two notes -- (1) I think that the AskBot text formatter ate some of @RonJon's code, so that's why it didn't run. (2) There are some subtle differences in the way that comments and answers are parsed in the AskBot software....weird!

qubit gravatar imagequbit ( 2012-12-23 14:39:01 +0200 )edit
1

answered 2012-12-20 01:17:15 +0200

RonJohn gravatar image

I'll try to be more specific, but what do you need to know?

Did you create the example test file like I documented?

Have you loaded your failing CSV file into a text editor to look at the failing line?

Does it always choke on the same line?

(The probable cause is bad data in the CSV file that LO Calc barfs on.)

edit flag offensive delete link more
0

answered 2014-04-29 15:18:27 +0200

EasyRider gravatar image

I got the same error, opening a .csv file in calc. The .csv file had quote marks (") delimiting all the text fields, as well as commas. I edited the .csv file, removing all the quote marks, and the error went away.

edit flag offensive delete link more
0

answered 2014-04-29 16:06:01 +0200

erAck gravatar image

Time to upgrade ... LibreOffice 3.4.5 is very old. Especially CSV import of files that do not strictly follow the CSV rules (and thus may have lead to "maximum number of rows exceeded" if for examples quotes don't match or embedded quotes were not escaped) was significantly improved with LibreOffice 3.6, see https://wiki.documentfoundation.org/R...

edit flag offensive delete link more
0

answered 2012-12-19 23:21:12 +0200

RonJohn gravatar image

Can you be more specific? (In bash I created a simple CSV and LO 3.6.4.3 opened it instantly.)

This is how I created the test file:

(for f in seq 1 63000; do echo > "foobar,$f"; done) > foobar.csv

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-12-19 21:13:12 +0200

Seen: 4,968 times

Last updated: Apr 29 '14