Ask Your Question
0

files resetting to "read only"

asked 2017-04-07 01:41:09 +0100

wimpy88 gravatar image

updated 2017-04-07 02:42:29 +0100

W10 PC Converting from Apache OpenOffice to LO (Version: 5.3.1.2). Beginning with first use of LO, files which never appeared as read only when opening are now only opening as read only. I reset the Properties General tab read only box and it works for a period of time, only to require another reset within 24 hours. I tire of having to repeat the "uncheck"process.

I am not doing anything differently, there seems to be no rhyme nor reason to when/if the files reset.

Anyone have a solution to this problem?

Thanks in advance

edit retag flag offensive close merge delete

Comments

What OS are you using, and what version of LO?

robleyd gravatar imagerobleyd ( 2017-04-07 02:25:36 +0100 )edit

edited post to supply answers.

wimpy88 gravatar imagewimpy88 ( 2017-04-07 02:44:00 +0100 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2019-08-05 14:27:25 +0100

DJPeter gravatar image

updated 2019-08-05 14:29:02 +0100

IF you have Dual boot with Windows then: When I opened and tried to edit files, The pop-up window read, "Error saving the document Passwords:Object not accessible. The object cannot be accessed due to insufficient user rights." I did notice on the main menu toolbar the "Window" tab there is a filed ticked as "(read-only) Libre-Writer." After two days i finally discovered that it was due to my dual boot with Windows. I booted in windows to play games, then shut down and booted into Linux mint. Then when I went to use libreoffice and other programs, I would get a error telling me that I was not the owner of the files and couldn't modify or delete them. At first it seemed Windows renamed my files and permissions but I found this https://www.howtogeek.com/349114/shut... https://www.howtogeek.com/395334/how-...

edit flag offensive delete link more
0

answered 2017-04-07 11:00:39 +0100

JohnHa gravatar image

updated 2017-04-11 11:14:13 +0100

You need to find out why the file is opening in RO Mode.

  1. Is it because the file needs to be unblocked because it has come from a different computer? (r-click the file > Properties > General > click Unblock)

  2. Is it because the file RO attribute is set? (r-click the file > Properties > General > untick RO)

  3. When you open the file with LO, is the setting under File > Properties > Security ..., set to RO?

  4. Is it because the user has not been given Write access to the file as a W10 ownership problem? (r-click the file > Properties > Security > Permissions ..., and check who owns the file and what permissions have been given)

  5. A "brute force and ignorance" solution may be to copy each file to a different folder, delete the originals, and replace them with the copies. This might remove the RO setting.

====

You say the RO attribute is set to RO. Find out why it is set to RO. Do a test - create a new document with LO and save it. Is the RO attribute ticked? If so, it is a bug in LO.

If this helps then please tick the answer and/or show you like it with an uptick.

edit flag offensive delete link more

Comments

WHY? The files RO attribute General Tab is checked. If I open with Apache OO, there is no problem. Your #1. Uploaded files from previous W7 PC hard drive, 5+ months using Apache OO. No issues with read-only. If I open with Libre OO, the RO attribute is checked. Since the last reset (your #2 & #3) the problem hasn't occurred. I will check for your solutions when I next encounter the problem. 4. Single user, owner/administrator privileges 5. Not an option, too many files.

wimpy88 gravatar imagewimpy88 ( 2017-04-08 02:41:25 +0100 )edit

You say the RO attribute is set to RO. Find out why it is set to RO. Do a test - create a new document with LO and save it. Is the RO attribute ticked? If so, it is a bug in LO.

JohnHa gravatar imageJohnHa ( 2017-04-11 12:43:26 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-04-07 01:41:09 +0100

Seen: 308 times

Last updated: Aug 05