Ask Your Question
0

How to insert an em-dash

asked 2017-04-10 23:46:14 +0200

LunixTheFirst gravatar image

I would like to use em dashes and en dashes in text, but don't see a way to insert them with the keyboard. How can it be done? I am typically using Liberation Serif as the font, but not always- sometimes it's Droid Sans or something else.

edit retag flag offensive close merge delete

Comments

I see that I can put a space before and after two regular dashes and auto-correct will change it. But I usually don't want a space before the dash.

LunixTheFirst gravatar imageLunixTheFirst ( 2017-04-11 00:02:42 +0200 )edit

What is your operating system?

gabix gravatar imagegabix ( 2017-04-11 09:48:49 +0200 )edit

Windows 10

LunixTheFirst gravatar imageLunixTheFirst ( 2017-04-11 21:45:32 +0200 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2017-04-11 01:50:53 +0200

m.a.riosv gravatar image

You can find how to do it in the Writer's guide page 80 https://wiki.documentfoundation.org/D...

edit flag offensive delete link more

Comments

Viola! It works!

LunixTheFirst gravatar imageLunixTheFirst ( 2017-04-11 21:48:19 +0200 )edit

THANK YOU VERY MUCH!

LunixTheFirst gravatar imageLunixTheFirst ( 2017-04-11 21:49:13 +0200 )edit
0

answered 2017-04-12 08:40:27 +0200

gabix gravatar image

For convenient input of many characters absent in standard layouts in Windows, try Ilya Birman's layout.

edit flag offensive delete link more
0

answered 2017-04-11 09:26:40 +0200

RGB-es gravatar image

Since a number of versions, LibO have autocorrects that do not need space before them: those surrounded by colons.

:---:

will turn into an m-dash as soon as you type the second colon while

:--:

will give you an en-dash and

:-:

a minus sign.

edit flag offensive delete link more

Comments

Thank you, RGB-es: I didn't see this happening when I tried it. I am running 5.1.6.2 (I had to downgrade because some stuff got broken in a newer version). Do you know which version implemented the behavior you describe?

LunixTheFirst gravatar imageLunixTheFirst ( 2017-04-11 10:14:12 +0200 )edit
RGB-es gravatar imageRGB-es ( 2017-04-11 10:55:38 +0200 )edit

Many thanks, RGB-es. Hmmm... why isn't it working? Have to check it on another machine or two.

LunixTheFirst gravatar imageLunixTheFirst ( 2017-04-11 21:46:19 +0200 )edit

This worked for me!

schulwitz gravatar imageschulwitz ( 2018-12-14 23:41:37 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-04-10 23:46:14 +0200

Seen: 5,863 times

Last updated: Apr 12 '17