"Due to an unexpected error, LibreOffice crashed." [closed]

asked 2017-04-15 11:04:18 +0100

jeshkhol gravatar image

updated 2017-08-24 16:10:39 +0100

macOS Sierra 10.12.4, MacBook Pro early 2015 LibreOffice 5.3.2.2 (and 5.2.6)

LibreOffice Writer keeps crashing for no apparent reason. While everything seems to be fine when working on an odt file, suddenly, out of the blue, LO crashes. The crash never really seems to be related to a particular task – maybe I was just typing text, or I was navigating the document, or I was changing a setting – and it occurs from anything within a few seconds to a few hours working on a file (that is, several times a day). The file may be a new one (with almost nothing in it yet) or an existing one. It happens both with the fresh and the still versions of LO.

Due to an unexpected error, LibreOffice crashed. All the files you were working on will now be saved.

I tried downloading Apache OpenOffice and using it, but OO behaves much in the same way in that it crashes unexpectedly. All other software works fine here.

On the positive side, Document Recovery works fine always, I don't seem to have lost any data so far.

I'd be very grateful if someone could point me to a solution.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by jeshkhol
close date 2017-04-15 17:06:07.098441

Comments

Please try resetting the user profile, sometimes solves strange issues. https://wiki.documentfoundation.org/U... Usually it's enough renaming/deleting the file "user/registrymodifications.xcu", it affects all the options in Menu/Tools/Options, and the files "user/basic/dialog.xlc" and "scrip.xlc" are overwritten, additionally custom colors in "user/config/standard.soc" are lost.

m.a.riosv gravatar imagem.a.riosv ( 2017-04-15 13:33:48 +0100 )edit

Thank you! Having followed the steps as given in the help page you linked to, I was using LO in safe mode, and the problem seemed to have gone indeed.

I have now deleted the file "registrymodifications.xcu" and hope the problem will be gone forever.

jeshkhol gravatar imagejeshkhol ( 2017-04-15 15:25:06 +0100 )edit

Unfortunately, it took only a few days for the mysterious crashes to resurge. I'm on 5.3.5.2 now, and LO continues to keep crashing. I really wish to have it work smoothly. Any tips?

jeshkhol gravatar imagejeshkhol ( 2017-08-24 16:08:18 +0100 )edit

Please test with Menu/Help/Restart in Safe Mode

m.a.riosv gravatar imagem.a.riosv ( 2017-08-25 13:40:22 +0100 )edit