Ask Your Question
0

Fonts are fuzzy and menu flickers after 5.3.2.2 update

asked 2017-04-16 14:28:35 +0100

wroot gravatar image

updated 2017-04-16 15:10:24 +0100

Was using 5.3.1.2. Today i have tried to update to 5.3.2.2 and after the update fonts in Calc are fuzzy and menu flickers when going through it. Looks like another OpenGl/video issue. I had to disable OpenGL through a registry after 5.1 update to make my fonts look ok and menus show text. OpenGL is still disabled (it says so in the View menu).

edit retag flag offensive close merge delete

4 Answers

Sort by » oldest newest most voted
1

answered 2017-04-16 18:24:39 +0100

timelord gravatar image

updated 2017-04-16 18:27:19 +0100

Related to the following bug reports.

bug report 107024

bug report 105863

edit flag offensive delete link more
1

answered 2017-04-20 08:02:25 +0100

vsfoote gravatar image

At 5.3.2 font rendering on Windows builds has been moved more completely to DirectWrite/Direct2D calls replacing remaining GDI only calls and its grayscale anti-alaising . It brings the non-OpenGL "Default" rendering to parity with "OpenGL" accelerated rendering providing more reliable cross platform text layout and shaping--but at the expense of some rendering quality on Windows builds for folks used to the "Default" rendering. ClearType anti-aliasing is not implemented.

Believe additional work is needed on the DirectWrite based font rendering and anti-aliasing, but the GDI and its grayscale anti-aliasing calls will likely not be restored.

See the bug report tdf#106990

Cause of the UI flicker affecting only "Default" rendering does not appear to be a driver issue, while users of "OpenGL" accelerated rendering are not affected. See bug report tdf#105863

edit flag offensive delete link more
0

answered 2017-04-16 15:10:00 +0100

updated 2017-04-16 15:10:58 +0100

Could be the notorious LO user profile corruption. Make sure LO is completely down, then rename the profile folder as guided in https://wiki.documentfoundation.org/U...

Could as well be graphics driver issue.

edit flag offensive delete link more

Comments

No this affects many users. Its a bug from LO

euro_rapp gravatar imageeuro_rapp ( 2017-05-27 13:55:27 +0100 )edit
0

answered 2017-06-05 13:44:37 +0100

wroot gravatar image

Thanks for the links to bug tracker tickets. I'm starting to strongly debate whether i should still be using (and donating money) LibreOffice. If i could just subscribe to Office 365. First i had to mess with registry and disable OpenGL after 5.1 for LO to even show text, now this. And comments from devs are like "you use windows, it's you problem"..

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2017-04-16 14:28:35 +0100

Seen: 1,923 times

Last updated: Jun 05 '17