Ask Your Question
0

All cells n all sheets are auto-formatted to Text. How to stop and change to numbers format? [closed]

asked 2017-04-17 01:59:27 +0100

eeSecur gravatar image

updated 2020-07-20 12:48:02 +0100

Alex Kemp gravatar image

Running OpenSuse x64 42.2 Leap. After a number system/application update all my sheets have a auto-text format for all previously formatted number cells. I have un-installed libreOffice and all related dependencies. Then re-install through OpenSuse Yast. This installed the latest version. Sadly when I open any sheet, all cells that previously had a number are still formatted as text. Have deleted or turned off all macros that I can find. Nothing seems to change the automatic text formatting. It takes about 1.5 -2 seconds for the entered number to change to blue and control returned to the keyboard.

Any advice or ideas will be tried.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2020-07-20 12:48:22.025104

Comments

If you go 'File'>'New>'Template' : Is there a template for spreadsheets marked as 'Standard'. If so you may reset the standard to default via the context menu of the emphasized template.
You can also edit that template and set all the cells to default cell format. Check also if the 'Default' cell style has the settings you want under 'Numbers'.
Template saved again should do now as expected.

Lupp gravatar imageLupp ( 2017-04-17 02:39:15 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2017-04-17 02:47:30 +0100

eeSecur gravatar image

Problem solved. Within linux local user space, turned on hidden-files. Under the hidden .config directory found and renamed the existing libreOffice directory which holds all local user libreoffice suite configuration files. These are created new when first run. I did find a few scripts related to changing numbers to text within the old libreoffice directory. Renaming these scripts or renaming them did not fix the auto-reformat issue. So just forced the creation of all default settings with the above folder rename.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2017-04-17 01:59:27 +0100

Seen: 159 times

Last updated: Apr 17 '17