Ask Your Question
1

Password protected files opening without a password. [closed]

asked 2012-12-25 05:41:04 +0200

enialm gravatar image

updated 2015-09-06 10:50:16 +0200

Alex Kemp gravatar image

Hi, I'm having a problem with .odt files that were created in LO Writer. When I open them they open without a password prompt when they are supposed to be password protected. Can anyone help? thanks Edit: I'm on a mac and it's LO version 3.6.4.3. I was just saving them with LO's password option.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-23 04:15:31.493192

3 Answers

Sort by » oldest newest most voted
0

answered 2014-05-21 14:17:51 +0200

Hey, had this same problem, my file was password protected and was working but then one day for no apparant reason it was no longer password protected. I tried

  • Tools
  • Protect Document
  • Save/close
  • Open

And that didn't work. However I did

  • Save As
  • Checked Save with password box
  • Entered password

And it is working again.

edit flag offensive delete link more
0

answered 2012-12-25 12:10:33 +0200

qubit gravatar image

Hi @enialm,

Could you please tell us what version of LO you're using and on what operating system?

Also, could you tell us what steps you're taking to save/encrypt the file and to open/decrypt the file? Here's a quick tutorial (I can't vouch for it -- I just googled it) that might help you write up some steps so we can try to reproduce ("repro") the problem you're having:

http://www.techntrix.com/create-password-protected-document-with-libre-office-writter/

edit flag offensive delete link more
0

answered 2012-12-27 00:15:33 +0200

qubit gravatar image

(Testing on Ubuntu 12.04 with LO 3.5.4.2)

Hi @enialm,

When I save a document using the 'Save with password' option, I have to re-enter that password before I can re-open the document.

Here are my repro steps

  • Create a new Writer document
  • Save As -> select 'Save with password' checkbox
  • Set a password for the file
  • Quit the LibreOffice program completely
  • Re-open the file
  • (at this point I am prompted for my password)
  • If I don't enter a password, or if I enter an incorrect password, the file will not open for me
edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-12-25 05:41:04 +0200

Seen: 5,401 times

Last updated: May 21 '14