Ask Your Question
0

Cannot edit imported data in Base

asked 2017-04-21 13:03:50 +0200

jordanyubin gravatar image

Hello.

I am using Libreoffice Base for my International GCSE ICT exam. I am practicing with past papers, but I can't get it to work. The files provided come as separate csv files, which have to be imported.

I have tried the following:

  • Importing the csv files directly from Base
  • Importing the csv file to Calc, then import the file to Base
  • Create a 2nd database, and copy the tables from the imported DB to the new file.

No matter what I try, I just can't seem to edit anything. All the editing options are greyed out (even things like cut, paste, etc...)

Can someone please help me?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2017-04-21 18:54:33 +0200

Ratslinger gravatar image

updated 2017-04-21 18:56:11 +0200

For some unknown reason my previous answer has disappeared. Here it is again.

Depending upon the method used, .csv and .txt files used in Base are read only. There is a method to open .csv file in a read/write fashion. See answer by @pierre-yves samyn - click here.

A similar procedure can be found in the LO documentation in Chapter 2 on page 19 - click here.

edit flag offensive delete link more

Comments

So I have to memorize SQL commands? I don't think I can do that, Internet access is banned during the exam.

jordanyubin gravatar imagejordanyubin ( 2017-04-22 18:17:42 +0200 )edit

It is starting to sound as if your question is incomplete. You only asked about editing a .csv file using Base. What is the process for the actual exam? Why are you using Base? Do you need to return the .csv file with answers?

Ratslinger gravatar imageRatslinger ( 2017-04-22 18:53:31 +0200 )edit

The exam requires me to add entries to a given database, perform queries, make reports with it, then print it.

jordanyubin gravatar imagejordanyubin ( 2017-04-23 16:36:47 +0200 )edit

If the mentioned method is not acceptable, use the copy/paste method from Calc. I have no problem with this process.

First, create the table with the field definitions. Transfer the .csv data to Calc (make sure field seperators are defined correctly). Select all cells in Calc with the data then right click & copy. On the Base table name, right click & select Paste. On the ensuing dialog box, make sure the correct table name is at the top, Append Data is selected, click "Create" button.

Ratslinger gravatar imageRatslinger ( 2017-04-23 19:59:32 +0200 )edit

Seems like that's the only solution that works. Thank you! Should I mark your answer as correct?

jordanyubin gravatar imagejordanyubin ( 2017-04-24 14:21:32 +0200 )edit

You can mark the answer if you accept the answer provided. I can only hope to provide you with something that will work for you.

Ratslinger gravatar imageRatslinger ( 2017-04-24 15:01:59 +0200 )edit
0

answered 2017-04-21 18:36:59 +0200

updated 2017-04-21 18:40:42 +0200

Ciao, have your tables a ID field set like primary key? Only so they are editable.

If my answer helped you, vote it with ✔, upper left area of answer

edit flag offensive delete link more

Comments

I did do that, but that changed nothing.

jordanyubin gravatar imagejordanyubin ( 2017-04-22 18:17:53 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-04-21 13:03:50 +0200

Seen: 35 times

Last updated: Apr 21