Ask Your Question
1

Calc Restore Row Heights to "Automatic" ("to max content height")? [closed]

asked 2012-12-26 18:36:11 +0200

JimBobH gravatar image

Hi.

I am noticing a puzzling/vexing behavior which I _think_ has been also vexing others in several forums, but I haven't seen a relevant reply so far (no solution, nor even confirmation that this is in fact the current behavior, or whether it is the intended behavior): When I first start entering data into a new spreadsheet (usually by typing, and setting Word Wrap on) I enjoy the fact that the Row Height increases and decreases automatically to fit cell contents as I edit. Then, for some reason, I adjust one or more row heights manually or by choosing Optimum in the dialog, then forever after the Automatic Row Height mode is no longer available for those Rows. I see nothing in the Help that tells how to turn on Automatic Row Height again. Is this because that is in fact impossible? If yes, please fix it. If no, please add the instructions to the Help, and reply here.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-03-06 17:54:46.297806

3 Answers

Sort by » oldest newest most voted
2

answered 2012-12-27 17:22:12 +0200

kohei gravatar image

You need to right-click on the row header (one that displays the row number, to the left of the area where the cells are), choose Optimal Row Height to bring up the optimal row height dialog. Leave whatever values are set in the dialog and click OK. That should reset the "automatic row height adjust" flag on for that row, to restore the original functionality.

edit flag offensive delete link more

Comments

Searching brought me to this thread. I have the same issue. The instructions above are NOT working. They are what I had been trying before I tried the LibreOffice Help, and then a Google search which brought me here.

DustyMojave gravatar imageDustyMojave ( 2014-07-02 04:01:13 +0200 )edit

With version 5.1.1.3 the row height goes auto only if Default value is checked, or the value is set to zero. Anything above zero will prevent the row's height from self-adjusting. If one needs to increase the default height for all rows, the proper way is to make use of styles: F11 -> Right Click on Default -> Modify -> Borders -> Spacing to Contents.

ted.w gravatar imageted.w ( 2016-03-28 11:40:31 +0200 )edit
0

answered 2013-01-07 03:25:09 +0200

JimBobH gravatar image

Excellent; thanks !

I'll try it and reply with results I see.

edit flag offensive delete link more

Comments

Doesn't work

Steven Monrad gravatar imageSteven Monrad ( 2019-03-25 19:03:45 +0200 )edit
0

answered 2014-11-30 13:02:44 +0200

What worked for me:

  1. Select the rows you want to affect (if whole sheet, click on the empty space in the top-left corner to select everything)
  2. Click on one of the selected row-headings (the number of the row)
  3. Click on "Optimal row height"
  4. Set the value 'Add' to 0,0 (if not already selected, this will switch on the option "Default value")
  5. Click "OK"
  6. Again:
    • Click on one of the selected row-headings (the number of the row)
    • Click on "Optimal row height"
  7. De-select "Default value"
  8. Click "OK"

I think this should reset the "automatic row height adjust" flag for the selected rows, to restore the original functionality.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-12-26 18:36:11 +0200

Seen: 22,827 times

Last updated: Nov 30 '14