Ask Your Question
0

set Language on Terminalserver for all users

asked 2017-05-16 08:33:09 +0200

BuX gravatar image

Hi, I roll out Libreoffice on a few Terminalservers. Some of them are in non-german speaking Countries, so i have to change the setup, so the user Interface is automatically set to english.

The Servers OS Systems are all deployed with the same (german) image, Windows 2008R2 x64 on VMWare.

my Install.bat is as follows:

set langs=en_UK,De (or De,en_UK for german Servers, gained from SET Parameters of the System)

set Options=/passive /norestart ADDLOCAL=ALL ALLUSERS=1 CREATEDESKTOPLINK=0 REGISTER_ALL_MSO_TYPES=1 REGISTER_NO_MSO_TYPES=0 ISCHECKFORPRODUCTUPDATES=0 REBOOTYESNO=No QUICKSTART=0 VC_REDIST=1 UI_LANGS=%langs% REMOVE=<langpacks and dictionaries not needed>

change user /install

:: do some uninstalls here

TASKKILL /F /IM SOFFICE.BIN

start /wait Msiexec.exe /qn /i LibreOffice_5.3.2_Win_x64.msi %Options% /l* c:\Logs\Libreoffice_5_3_2_2_Server_Install.log
xcopy *.xcd "%programfiles%\LibreOffice 5\share\registry\" /E /H /R /C /I /Y 

change user /execute

This does not work. All Users get their Libreoffice installed in German, no matter which .msi i use, German or English one.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2017-05-16 08:51:50 +0200

updated 2017-05-16 17:03:22 +0200

You might try a GPO template to configure the settings for any user in a Windows domain. Also, you might tweak registry files as mentioned in "Post-deployment configuration" here.

no matter which .msi i use, German or English one

There's no "German or English" msi; TDF creates single all-language MSI.

To set e.g. en-GB as user default UI, create a new XML file with xcd extension in <LibreOffice insdir>\share\registry, e.g. UILang.xcd, and put this into it:

<?xml version="1.0"?>
<oor:data xmlns:xs="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:oor="http://openoffice.org/2001/registry">
  <dependency file="main" />
  <oor:component-data xmlns:install="http://openoffice.org/2004/installation"
  oor:name="Linguistic" oor:package="org.openoffice.Office">
    <node oor:name="General">
      <prop oor:name="UILocale" oor:op="fuse">
        <value>en-GB</value>
      </prop>
    </node>
  </oor:component-data>
</oor:data>

This will make any new user profile to have this UI language set by default.

edit flag offensive delete link more

Comments

ok, but which settings do i need to change? i have not found anything in documentation on how to change the language of the menu bar except by manually changing it for every user via Tools --> Options --> Language Settings --> Languages --> User interface How do i find which settings to change (how they are named) for changing these settings globally (of in user settings, if necessary)? Changing the ooLocale Value in registrymodificatins.xcu does not seem to have any effect.

BuX gravatar imageBuX ( 2017-05-16 13:22:37 +0200 )edit

To find which setting you need to change, just backup your registrymodificatins.xcu, then make necessary changes, and then compare the registrymodificatins.xcu with backup.

In this case, the key is /org.openoffice.Office.Linguistic/General-UILocale.

Mike Kaganski gravatar imageMike Kaganski ( 2017-05-16 13:39:50 +0200 )edit

Thank you, setting the UILocale Variable to "en-GB" resprective "de" workes fine. It's however sad that this behaviour cannot be set globally to a server (since users must work from their home drive i cannot simply change the Default User Settings) Thank you for the fast help!

BuX gravatar imageBuX ( 2017-05-16 16:43:45 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-05-16 08:33:09 +0200

Seen: 535 times

Last updated: May 16 '17