Ask Your Question
0

Associate odt with Libreoffice [closed]

asked 2013-01-11 15:07:05 +0200

Bravos gravatar image

updated 2014-01-07 20:41:52 +0200

manj_k gravatar image

Since changing to Libreoffice a few months ago I have been opening doc programs using the right click contextual menu and 'Open With'. Once saved as odt format then they opened automatically with Libreoffice.

I now find that I cannot open odt files directly using this method and have to open Libreoffice first and then open the file from there.

The right click contextual menu now offers 2 'Opens'. One says it can't open the file and the other opens it in Wordpad.

When I used Control Panel to associate the odt file type with Libreoffice I find that it is not listed.
See: http://screencast.com/t/Qp0QrqO76u1

Would appreciate any suggestions.

Regards Bruce

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-18 11:14:19.408975

Comments

manj_k gravatar imagemanj_k ( 2014-01-07 20:42:38 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2013-01-13 17:54:15 +0200

qubit gravatar image

updated 2013-01-23 08:05:20 +0200

I believe the easiest way to (re)associate file types with LibreOffice is to just run the installer.

UPDATE: see @manj_k's link below -- the 'REPAIR' option sounds like an even faster way to re-associate the file formats with LibreOffice.

Each operating system has a different mechanism for setting the default program to open certain types of files (based on MIME types, file extensions, etc...); IIRC, the LO Installer has a relatively standardized mechanism for choosing which file types to associate with LibreOffice.

If you don't happen to have the latest version of LO installed, this is a perfect excuse to upgrade... :-)

(If you install LO from source or by using a package manager, then you'll probably want to use your platform-specific mechanisms. Let us know if you have additional questions)

edit flag offensive delete link more

Comments

1
manj_k gravatar imagemanj_k ( 2013-01-14 12:19:36 +0200 )edit

I have installed 4.1.4 on my Windows 7 machine and it will not associate any file extensions to LO using any method. I have gone through the sequence: uninstall LO, reboot, redownload and install, reboot. Still no associations or ability to establish an association. LO works when started manually.

Kent Smith gravatar imageKent Smith ( 2014-01-06 16:16:23 +0200 )edit

The year attached to the "Comments" in this system is wrong! ('13 rt '14) I don't know how to get this info to the powers that be... :)

Kent Smith gravatar imageKent Smith ( 2014-01-06 16:29:06 +0200 )edit

You may try:

Windows Start button → Default Programs → Associate a file type or protocol with a program ...

Detailed: http://windows.microsoft.com/en-us/windows/change-default-programs#1TC=windows-7

manj_k gravatar imagemanj_k ( 2014-01-06 21:59:20 +0200 )edit

That was one of the first things I tried. LO doesn't show up in the list of apps. I browse to soffice.exe and select it but it is not recognized when I click on open.

Kent Smith gravatar imageKent Smith ( 2014-01-07 15:54:41 +0200 )edit

I searched through the registry and as best I can tell everything is there. LibreOffice appears in the applications lists. All the paths are to what they should be. The "Open with" lists all list soffice.exe and/or swirter.exe -- although the also list soffice.bin -- is that normal?

Kent Smith gravatar imageKent Smith ( 2014-01-07 16:21:35 +0200 )edit

I referred to this window(here: Win7 · German).

E.g.: .odt = LibreOffice Writer = swriter.exe
etc.

manj_k gravatar imagemanj_k ( 2014-01-07 20:30:00 +0200 )edit

Yes. that is the process I tried first -- I browse to find swriter.exe and select it but it is not put into place.

Kent Smith gravatar imageKent Smith ( 2014-01-08 21:45:24 +0200 )edit

@Kent Smith – Best would be to post a new question (with as much information as possible), because this thread has been marked as resolved.

manj_k gravatar imagemanj_k ( 2014-01-09 00:08:29 +0200 )edit

AHHHH! Thank you!

Kent Smith gravatar imageKent Smith ( 2014-01-09 00:37:52 +0200 )edit

Question Tools

Stats

Asked: 2013-01-11 15:07:05 +0200

Seen: 1,333 times

Last updated: Jan 07 '14