Ask Your Question
0

How to prevent LibreOffice from opening the browser when clicking on a link? [closed]

asked 2013-01-11 22:59:24 +0200

bread-crumb-sandwitch gravatar image

updated 2015-10-20 00:39:40 +0200

Alex Kemp gravatar image

I would like to be able to keep the text in my document 'linkified', but not be redirected to my standard browser when clicking on it. Alternatively, would there be a possibility to set a dialogue box asking for confirmation before firing up the browser?

This change should apply to all types of links (mailto, http, ftp, ...).

I also noticed a strange behaviour in LibreOffice 3.5.7.2 Linux - Fedora 17:

When I clicking on a link the default browser opens, but it also reverts back to the default setting (no Addons, no Themes, ...). It is annoying and could potentially be a privacy and security risk (changed proxy settings, security Addons like NoScript not available). I say 'potentially' because I am competent to make any definite statements on that matter.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-20 00:40:22.447383

1 Answer

Sort by » oldest newest most voted
1

answered 2013-01-13 16:00:46 +0200

qubit gravatar image

updated 2013-01-13 18:00:34 +0200

(Using LO 3.5.4. Ubuntu 12.04.1)

Okay, I have good news and bad news for you...

First, Under

Tools -> Options -> LibreOffice -> Security -> Options (Security Options and Warnings), inside the 'Security options' section:

I have an (enabled) checkbox that is labeled "Ctrl-click required to follow hyperlinks".

The bad news is that this feature only seems to work in LibreOffice Writer. Whether the option is enabled or disabled, single-clicking links in LibreOffice Calc immediately opens a new browser window.

Update: Bug report about this problem (filed in June) is here: fdo#51296

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-01-11 22:59:24 +0200

Seen: 1,578 times

Last updated: Jan 13 '13