Ask Your Question
0

LibreOffice access to Google Drive asks for authentication 6-digit pin

asked 2017-06-07 22:34:58 +0200

aarone gravatar image

When I try to save a document to my google drive account, after adding google credentials I'm asked to put a 6-digit authentication pin. How do I get it?

thanks!

edit retag flag offensive close merge delete

Comments

Good question.

I've decided to make the switch to LibreOffice (on Windows 10) from Office. I tried to connect to my Google Drive (which has 2FA) and this is the same problem that I encountered. All in my first ten minutes. Worse, is that though this question has received over 3,000 views, not one person from the developers or the user community is willing to offer an answer. In all, not the greatest welcoming experience or first impression for a new user.

Any ideas? Anyone?

libusr gravatar imagelibusr ( 2018-04-24 17:46:40 +0200 )edit

There is a work around...but you must have access to your Google Drive from within your computer's directory system.

If you have, then you can ignore the seeming non-functionality of 'Save Remote' and instead simply select 'Save As' and locate the Google Drive directory as the destination for your saved file.

libusr gravatar imagelibusr ( 2018-04-24 17:54:51 +0200 )edit

This is a two step/phase verification. You must provide your mobile number to Google for them to send you a SMS text message to your mobile phone in order for you to authenticate on the system. Either the number on your account is incorrect or the phone number does not accept SMS messages. You can set this up on multiple social sites such as Facebook, Intstagram, LinkedIn, etc. Which is a good idea to keep your accounts your own.

Daverrr gravatar imageDaverrr ( 2018-05-16 17:44:05 +0200 )edit

5 Answers

Sort by » oldest newest most voted
2

answered 2018-09-05 08:36:40 +0200

sberg gravatar image

updated 2018-09-05 09:57:51 +0200

Found that, depending on the characters in your username/password, they were not correctly encoded when talking to Google, so authentication failed (and the code then falls back to asking for a two-factor 6-digit pin but which you wouldn't receive from Google, whether or not you have two-factor authentication enabled for your account). Should be fixed with https://gerrit.libreoffice.org/#/c/59986/ "Properly encode OAuth2 credentials" (on master towards LO 6.2, but there's also backports to 6.0.x and 6.1.x planned; see that link for details).

edit flag offensive delete link more

Comments

@sberg Many thanks for the post. Have tried to answer this many times since it always worked for me but others seemed to continue with problems. Good to know where the problem is and that there is a fix coming.

Ratslinger gravatar imageRatslinger ( 2018-09-05 20:21:57 +0200 )edit
0

answered 2017-06-08 04:47:57 +0200

robleyd gravatar image

This sounds like the Google Drive account has been set up with Two Step Verification. For more info, see https://www.google.com/landing/2step/...

If this answer helped you, please accept it by clicking the check mark ✔ to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

edit flag offensive delete link more

Comments

Well, my account is set up with 2FA - but Google is not sending the authcode :-# (tested with LO5.2.5.1 openSuse & vanilla)

komma4 gravatar imagekomma4 ( 2017-06-08 08:53:49 +0200 )edit

Same here. I, too, have 2FA set up on my account. Judging by the lack of comments on this topic, I am guessing that virtually no one uses "Save to Remote Location" in LO. That's unfortunate. Maybe they don't use it because they cannot find an answer to this problem (6-pin digit number).

upgrade2.com gravatar imageupgrade2.com ( 2017-10-29 14:40:14 +0200 )edit
0

answered 2018-05-16 17:26:23 +0200

this worked for me. set up 2 step verification on google and make it send a code to your phone via text. now when i access my google drive in libre office it sends a 6 digit code to my phone and i put that into the box, that's it.

edit flag offensive delete link more
0

answered 2017-06-08 08:12:48 +0200

aarone gravatar image

Well, that is the issue. LibreOffice (or google drive authentication) behaves as if the two step verification is enabled for my account, while actually it is not.

edit flag offensive delete link more

Comments

Even worse. I have two step authentication, but I have the authenticator app. I get a message to which I am supposed to click "Yes It' s Me" which has no effect. The authenticator app also has a 6 digit numerical code that has no effect as a password either. The remote files feature, while it would be nice to have seems to be severely broken and needs lots of love and care.

juaninse gravatar imagejuaninse ( 2018-05-28 22:59:20 +0200 )edit
0

answered 2017-11-08 20:17:15 +0200

Joe H gravatar image

I saw the 'Open Remote File' option today for the first time and decided to try it as I have files on Google Drive. I do have 2FA enabled so I was not surprised to get authentication from my phone but it does not provide me with a code. Instead it just asks me to confirm that I am logging in from another computer. As LibreOffice will not proceed without the code, even though the 2FA worked, I am stuck. Any suggestions?

edit flag offensive delete link more

Comments

@Joe H See my answer on this post. Has worked repeatedly for me.

Ratslinger gravatar imageRatslinger ( 2017-11-08 20:33:37 +0200 )edit

thanks @Ratslinger this also worked for me :)

cicindel gravatar imagecicindel ( 2018-06-08 09:24:10 +0200 )edit

Joe this worked for me until I enabled 2-step authorization. now get a "General Input.output error"

kmcaron gravatar imagekmcaron ( 2018-08-08 04:01:27 +0200 )edit
Login/Signup to Answer

Question Tools

5 followers

Stats

Asked: 2017-06-07 22:34:58 +0200

Seen: 6,230 times

Last updated: Sep 05