Ask Your Question
2

LibreOffice access to Google Drive asks for authentication 6-digit pin

asked 2017-06-07 22:34:58 +0200

aarone gravatar image

updated 2020-07-10 22:01:13 +0200

Alex Kemp gravatar image

When I try to save a document to my google drive account, after adding google credentials I'm asked to put a 6-digit authentication pin. How do I get it?

thanks!

edit retag flag offensive close merge delete

Comments

Good question.

I've decided to make the switch to LibreOffice (on Windows 10) from Office. I tried to connect to my Google Drive (which has 2FA) and this is the same problem that I encountered. All in my first ten minutes. Worse, is that though this question has received over 3,000 views, not one person from the developers or the user community is willing to offer an answer. In all, not the greatest welcoming experience or first impression for a new user.

Any ideas? Anyone?

libusr gravatar imagelibusr ( 2018-04-24 17:46:40 +0200 )edit

There is a work around...but you must have access to your Google Drive from within your computer's directory system.

If you have, then you can ignore the seeming non-functionality of 'Save Remote' and instead simply select 'Save As' and locate the Google Drive directory as the destination for your saved file.

libusr gravatar imagelibusr ( 2018-04-24 17:54:51 +0200 )edit

This is a two step/phase verification. You must provide your mobile number to Google for them to send you a SMS text message to your mobile phone in order for you to authenticate on the system. Either the number on your account is incorrect or the phone number does not accept SMS messages. You can set this up on multiple social sites such as Facebook, Intstagram, LinkedIn, etc. Which is a good idea to keep your accounts your own.

Daverrr gravatar imageDaverrr ( 2018-05-16 17:44:05 +0200 )edit

I gave Google my mobile number, and let turned on 2FA with it. It does not send the confirmation texts though. I also tried using Google Auth. I got it to prompt me for the auth code from Google Auth, when signing in to gmail on the desktop computer web browser. That confirms that it was 2FA was successfully turned on. When I try to save the file to the remote drive, LibreOffice says the drive is invalid. LibreOffice 6.2.8.2-2.fc30 on Linux

bpracht gravatar imagebpracht ( 2019-11-16 22:27:50 +0200 )edit

14 Answers

Sort by » oldest newest most voted
0

answered 2017-06-08 04:47:57 +0200

robleyd gravatar image

This sounds like the Google Drive account has been set up with Two Step Verification. For more info, see https://www.google.com/landing/2step/...

If this answer helped you, please accept it by clicking the check mark ✔ to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

edit flag offensive delete link more

Comments

Well, my account is set up with 2FA - but Google is not sending the authcode :-# (tested with LO5.2.5.1 openSuse & vanilla)

komma4 gravatar imagekomma4 ( 2017-06-08 08:53:49 +0200 )edit

Same here. I, too, have 2FA set up on my account. Judging by the lack of comments on this topic, I am guessing that virtually no one uses "Save to Remote Location" in LO. That's unfortunate. Maybe they don't use it because they cannot find an answer to this problem (6-pin digit number).

upgrade2.com gravatar imageupgrade2.com ( 2017-10-29 14:40:14 +0200 )edit
0

answered 2018-05-16 17:26:23 +0200

this worked for me. set up 2 step verification on google and make it send a code to your phone via text. now when i access my google drive in libre office it sends a 6 digit code to my phone and i put that into the box, that's it.

edit flag offensive delete link more
0

answered 2020-04-15 13:14:44 +0200

Bastiaan gravatar image

updated 2020-04-15 13:25:20 +0200

On linux it turns out you can just use gnome's online accountsto connect to google (and i suppose KDE has a version too). The drive will appear in your file manager (file aka nautilus) as youraccountname@gmail.com. You can then use the 'normal' way of opening all your files located on your google drive.

I was puzzled by this too. I do not want to give my phone number to google, then what? Would be nice if a user can choose which authentication method to use in the first place and that libreoffice is just recognizing the gnome online accounts already created and lists them automatically in the remote services.

One thing I noticed. I cannot open files from the filemanager directly by double clicking a file as the google-drive file format was not recognised. I can open them via libreoffice directly

edit flag offensive delete link more
0

answered 2019-11-17 14:48:16 +0200

daifu gravatar image

updated 2019-11-17 14:51:10 +0200

This worked for me. It all has to do with Google apparently. This is what I do to solve Libreoffice's login into Gdrive on my computer. I run DEBIAN 10

  1. Go into GMail
  2. Go to MANAGE YOUR GOOGLE ACCOUNT (it's right upper corner under the icon for your account)
  3. Go to SECURITY
  4. SECURE ACCOUNT
  5. SECURITY ISSUES FOUND - I found Libreoffice listed here
  6. Grant access to Libreoffice (it will ask if you are sure - say YES)
  7. Make sure under Signing in to Google you signin the old fashion way, no phone, no 2 step verification. Plain email and password signin
  8. Turn on Less secure app access
  9. Make sure you are auto signing in into your ONLINE ACCOUNTS in your computer.
  10. I had to reboot to have everything working

Can someone verify if this works. I will be trying this on my work's computer this week also. Let you know

edit flag offensive delete link more

Comments

Still doesn't work.

Ratslinger gravatar imageRatslinger ( 2019-11-17 23:11:06 +0200 )edit
Login/Signup to Answer

Question Tools

8 followers

Stats

Asked: 2017-06-07 22:34:58 +0200

Seen: 29,425 times

Last updated: Apr 15