Ask Your Question
0

LibreOffice dialogs (file open, file save, etc) appearing with window contents misalligned with window geometry. Anyone know what is wrong? See details for system particulars

asked 2017-06-12 20:01:20 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I am running LibreOffice on Debian (Stretch/9) with Xorg X and IceWM window manager. All apps are from debian repo's and are current versions as delivered by apt-get. All of my LibreOffice dialog boxes (file open, file save, etc) are appearing with the contents mis-allgined with the borders of the dialog window (imagine a window with it's contents moved up and left a few dozen pixles - not just the text, but everything - as if it were cut and re-pasted in the incorrect location). The area between the window border and the beginning of the window contents is black. Clicking anywhere in the black area of the dialog window instantly corrects the mis-allignment, but clicking on the dialog window anywhere other than the black area does not. Also, clicking on any other app (ie: WM triggered focus change) causes the alignment issue with the LO dialog box to correct (makes getting a screenshot a PITA).

Anyone have any suggestions as to why this is? As of yet, I can't find any of my other applications that have this issue, so it seems to be LibreOffice specific.

Update: This appears to be specific to running under IceWM. I tested with OpenBox and the behavior did not repeat.

Update 2: Apache OpenOffice does not suffer the same problem, despite being (presumably) a very similar code-base.

Update 3: I tested with OpenGL off and OpenGL on - no change in behavior.

Edit 4: Re-read the original description - more precise explanation of behavior added.

Edit 5: Update - tested on CentOS 6.x as the base OS, and the behavior does not duplicate. Furthermore, the dialog boxes appear substantially different - as if using a whole different library for their generation (they looks very QT/KDE/similar-ish on my Debian 9 system, and they look very gnome-ish on my CentOS 6 box).

UPDATE: My strong suspicion at this point is that there is a 3rd party library (or libraries) that LibreOffice depends on that is the root cause here. Does anyone know what library or libraries LibreOffice uses to create/display dialog boxes?

Thanks in advance. Below is a screenshot.

image description

edit retag flag offensive close merge delete

Comments

SOLVED: apt install libreoffice-gnome fixed it - it is now using the gnome libraries to render the dialog boxes, which works great.

Probably a thing for Debian Package Maintainers to fix, not Libreoffice folks proper.

BrotherJack gravatar imageBrotherJack ( 2017-07-05 23:13:37 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2017-07-05 23:03:06 +0200

BrotherJack gravatar image

updated 2017-07-05 23:16:03 +0200

SOLVED: tl;dr - anyone with my issue here needs to 'apt install libreoffice-gnome' (or libreoffice-kde would probably also do it).

Clues: As noted in the update to the original post - I tried this in CentOS 6, identical LibreOffice version (5.2.7.2), same IceWM versions (1.3.8), and I get very different behavior. On the CentOS system, the dialog boxes look totally different - same elements, but layout/etc is all completely different. Without knowing exactly - I'd say on Debian it looks like the dialog boxes come from the libQT universe (or similar), and on the CentOS system they come from the Gnome universe (or similar).

So my strong suspicion at this point, is that LibreOffice uses a 3rd party library (or probably more likely one of multiple libraries) to provide rendering of dialog box contents, and whatever one in use on my Debian system when using IceWM, there is a bug. Since it changes the behavior to run OpenBox - I am going to assume it's a library load order thing maybe?

Some research along those lines found that there is a libreoffice-gnome package available on Debian, which is the Gnome integration bits. I installed that package, which resolved the issue.

Thanks,

edit flag offensive delete link more
0

answered 2017-06-16 22:47:20 +0200

m.a.riosv gravatar image

Please test disabling Menu/Tools/Options/LibreOffice/View - OpenGl

edit flag offensive delete link more

Comments

I have tried it with OpenGL both enabled and disbaled, and it did not change the behavior at all. It suffers the issue in both cases.

BrotherJack gravatar imageBrotherJack ( 2017-06-19 18:14:32 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-06-12 20:01:20 +0200

Seen: 658 times

Last updated: Jul 05 '17