Ask Your Question

marcus hall's profile - activity

2016-03-11 12:46:34 +0200 received badge  Notable Question (source)
2016-03-11 12:46:34 +0200 received badge  Famous Question (source)
2015-08-21 05:52:08 +0200 received badge  Popular Question (source)
2015-08-20 20:23:46 +0200 answered a question Fedora 22 upgrade, spell check not working

OK, I have found what solved the problem for me..

Under Tools->Options->Language Settings:Writing Aids, the list of available language modules showed almost everything set. I unchecked and then re-checked "Hunspell SpellChecker" and "Libhyphen Hyphenator" and hit OK. (I strongly suspect that the hunspell was the significant checkbox). Then, when I go back to Language and look at the default language settings, the "English (USA)" entry has the ABC✔ by it, and now spell checking is working.

Best guess is that some results of invoking something from hunspell is saved by libreoffice and that with updating versions, the cached output is no longer valid. Re-invoking (when re-checking the checkbox) refreshes the cached data and now everything is all better.

2015-08-20 20:03:18 +0200 commented answer Fedora 22 upgrade, spell check not working

..... systems..

Just what information tells libreoffice which spellcheck dictionaries are installed anyhow? Is there a directory with the databases present, or an XML file somewhere? I suppose that I can compare all files owned by libreoffice packages and see if there is a difference somewhere between the working and failed systems...

2015-08-20 20:01:08 +0200 commented answer Fedora 22 upgrade, spell check not working

I will try removing all of the packages and re-installing in the near future.. Besides the ~/.config/libreoffice directory, what other configuration information is there to remove?

It seems like a system install sort of a problem, since the issue happens for all users on the systems that failed (about 4 out of 5 systems upgraded) and seems to be fine on the one system I know still works. I have verified that all of the packages installed on the working system are installed on the failed......

2015-08-20 15:56:27 +0200 commented answer Fedora 22 upgrade, spell check not working

OK, I removed ~/.config/libreoffice and let it re-create things. The old version had a "3" subdirectory and it re-created a version with a "4" subdirectory. Still, no spellchecking on English (USA), just all of the other English (XXX) variations.

2015-08-19 20:31:05 +0200 commented answer Fedora 22 upgrade, spell check not working

As I had concluded above, the ABC✔ not being present on "English (USA)" is an indicator that spell checking isn't present. But, it is present for the 15 other flavors of english. Why that is so seems to be the root of the issue.

I did rename the ~/.libreoffice directory, but that did not make any difference.

2015-08-19 20:27:37 +0200 received badge  Scholar (source)
2015-08-19 16:36:36 +0200 asked a question Fedora 22 upgrade, spell check not working

I have upgraded several systems to Fedora 22 (Libreoffice 4.4.5.2) and have now discovered that the auto spell checking is no longer working. That is, a misspelled word used to get a red squiggled line under it and produce suggestions on the correct spelling.

One suggestion that I have seen is to re-set the default language to "English (USA)". For some of the systems, this has worked and auto spell check is working, but on other systems this seems to not be working.

On the systems that are not working, the pull-down list showing all of the available languages shows an icon that looks like "ABC" and a check next to all of the english options EXCEPT for "English (USA)". On the systems that are working, this icon is present only on the "English (USA)". I interpret the icon to indicate that spell checking is available for these languages, and indeed, if I select "English (UK)" or any other choice with the icon, I do get auto spell checking.

I did see mention of installing "libreoffice-langpack-en". There were no language packs installed initially. After installing this, however, the situation has not changed.

So, the question is, how did I get all variations of English enabled for spell checking EXCEPT for USA, and, more importantly, how do I fix it?

Thanks!

marcus hall marcus@tuells.org

[Edit: added lo4.4.5 tag]

2014-05-02 21:22:17 +0200 received badge  Famous Question (source)
2014-04-13 11:08:56 +0200 received badge  Notable Question (source)
2014-04-12 22:16:28 +0200 received badge  Self-Learner (source)
2014-04-12 22:16:28 +0200 received badge  Teacher (source)
2014-04-12 22:04:25 +0200 answered a question Suddenly cannot edit tables within a document..

Yes, this was an issue that "Table->Table Boundaries" was not checked. I'm not sure where the settings are saved, since I thought I had removed all of the settings so that my wife would go back to the defaults, and I don't recall ever setting that for myself, so I imagine that I was set up for the defaults..

Nevertheless, that does seem to have cured the problem. Thanks!

2014-04-11 22:02:33 +0200 received badge  Popular Question (source)
2014-04-11 05:44:48 +0200 asked a question Suddenly cannot edit tables within a document..

My wife has suddenly encountered a problem with libreoffice writer where the border lines in tables have disappeared in the document and the print. If I open the document on my computer, everything is fine. If I log in to her computer and edit the document, everything is fine. We have discovered that she also cannot add rows or columns to the tables. If she prints the doucment, the table borders do not print, but if I print it they do.

This is for libreoffice 4.2.3.2 on Fedora 20.

I have removed .config/libreoffice in her directory and re-started to no effect, so it doesn't seem to be a libreoffice setting that is getting confused. I have restored her entire .config directory from two weeks ago (when things were working fine) and the problem still persists.

Any suggestions what to try next? This is totally baffling..

marcus hall marcus@tuells.org