Ask Your Question

Charlie-F's profile - activity

2015-08-12 17:55:15 +0200 received badge  Famous Question (source)
2014-06-04 05:06:54 +0200 received badge  Notable Question (source)
2014-05-20 19:41:47 +0200 received badge  Popular Question (source)
2014-05-20 13:16:17 +0200 commented answer Hyperlink pointing to macro no longer works.

Do I read this correctly? A hyperlink to a macro was never officially supported and just happened to work?

Is this considered a bug or just another example of an unsupported interface.

2014-05-19 23:21:51 +0200 received badge  Student (source)
2014-05-19 21:50:17 +0200 asked a question Hyperlink pointing to macro no longer works.

After upgrading to LibreOffice Version: 4.2.3.3 Build ID: 420m0(Build:3) on Xubuntu 14.04, hyperlinks that point to macros no longer work. I'm aware of the Ctl-Click option, but that has no effect. My hyperlinks that point to files work as before (now that I use Ctl-Click). I have several spreadsheets that have been around for 5 years or more that use hyperlinks to call a macro. All of these hyperlinks worked on the previous system (Ubuntu 12.04, but I'm not sure what release of LibreOffice).

For example, in the column header of a DATE column I use =HYPERLINK("macro://./Standard.Sort._SortByDate","Date") to call my _SortByDate macro. If I click Tools/Macros/Run Macro... I can run the macro. If I Ctl-Click on the hyperlink nothing happens and I get no error message. If I open the Basic editor and set a breakpoint inside the macro I get no evidence that the macro has been called.