Ask Your Question

bgman's profile - activity

2018-07-31 10:31:22 +0200 received badge  Famous Question (source)
2018-07-31 10:31:22 +0200 received badge  Notable Question (source)
2016-11-23 23:05:28 +0200 received badge  Popular Question (source)
2016-11-23 19:42:26 +0200 answered a question Drop Down in cell

Thank you so much. I'm fairly certain I tried that. What I had not done was close and then reopen the file. When I just opened to try your solution - it was gone.

Bob.

2016-11-23 17:32:24 +0200 asked a question Drop Down in cell

I have a calc cell that has started displaying a drop down list with several selections above a list. The selections are: Sort Ascending, Sort Descending, Top 10, Empty, Not Empty and Standard Filter. There is a text box for Search items...

I seem to not have enough points to include or attach a screen capture. Has anyone seen this? What is it? How do I get rid of it?

Libreoffice Calc version 5.1.4.2 Ubuntu 16.04 Cinnamon 3.0.7

Thanks, as always, to anyone kind enough to help!! Bob

2016-03-14 00:23:33 +0200 received badge  Famous Question (source)
2016-03-14 00:23:33 +0200 received badge  Notable Question (source)
2016-03-14 00:23:33 +0200 received badge  Popular Question (source)
2015-11-18 06:21:50 +0200 received badge  Popular Question (source)
2015-11-17 21:20:55 +0200 received badge  Editor (source)
2015-11-17 20:57:15 +0200 asked a question command line convert to csv save cell content as shown

When I save a calc file as csv using the File - Save As menu, I'm given an option to "Save cell content as shown" or I could "Save formulas". Is there a way to force the "Save cell content as shown" when performing the conversion from the command line?

The cells affected are those with a call to a libreoffice basic macro. Those cells only display #NAME? following the command line conversion. Following the File-Save As conversion, these cells all display the corrected calculated value.

My python code:

return_code = subprocess.call("soffice -env:UserInstallation=file:///tmp/tempprofile --headless --convert-to csv " + InputFile + " > null", shell=True)

I'm using LO 4.4.6.3 in Ubuntu 15.04, python 2.7.9.

Many thanks to any and all!!

2015-09-09 18:25:56 +0200 answered a question convert-to command line parameter

I'm using LibreOffice Version: 4.3.7.2, running on Ubuntu 14.10. Using the above and other questions and answers I've gotten the following command to work. The headless option is discussed above. The env parameter allows the command to run even if libreoffice is already running.

soffice -env:UserInstallation=file:///tmp/tempprofile --headless --convert-to csv FileName

I do have an additional problem. The spreadsheets I'm converting to csv have a libreoffice basic function. When I use the GUI to convert to csv, the values as displayed go into the csv file. When I use the command line, all I get is #VALUE!.

Is there a way to get the correct, calculated value, into the csv file?

Thanks for any answers!!

2015-09-07 19:47:10 +0200 asked a question Convert multisheet calc file to csv

How can I control which worksheet gets converted? I'm using the command: soffice -env:UserInstallation=file:///tmp/tempprofile --headless --convert-to csv Test.ods

This seems to work very well in testing, but then I realized that I hadn't considered multi-worksheet files. How can I specify which worksheet to convert?

I'm running Ubuntu 14.10, LO Version: 4.3.7.2.

Thanks to all!

2015-01-03 03:59:50 +0200 received badge  Famous Question (source)
2014-11-08 02:02:19 +0200 commented answer mail-merge failing

As in the thread you linked to above - killing LO and restarting restores mail merge to functionality. Not ideal, but at least doable. I only have to run one mail merge every few days so i can do this. Presumably, Logging out and back in as in my comment below accomplished the same thing.

2014-11-08 01:42:07 +0200 received badge  Notable Question (source)
2014-11-07 15:53:12 +0200 answered a question Mail Merge doesn't save files

I've had a similar problem. See my question here.

The only progress that I've made is to log out and back in. That has worked the one time I tried. I'll need to print mail merge docs later today and will be trying again.

2014-11-06 15:58:25 +0200 received badge  Popular Question (source)
2014-11-05 20:53:39 +0200 answered a question mail-merge failing

Not an answer - but additional info. I just logged out and back in (not a restart - just a log out and in) and the exact same steps, starting with opening a LO writer odt file and everything worked as expected. The printer select dialog box opened and I was able to select printer and options and print the report.

Any ideas what would cause that behavior??

2014-11-05 20:44:51 +0200 asked a question mail-merge failing

I've been using mail merge in open and libre office for several years now. I recently upgraded to LO 4.2.6.3 running on linux mint 17 64 bit. Mail merge has become very unreliable. Sometimes it works and usually it doesn't.

I use spreadsheets as the data source. I've created database files by opening LO Base, connecting to existing DB, DB type spreadsheet. I have 3 odb files or databases stored in the /home/username/Documents folder.

I have opened a LO writer odt file that has field names for one of these databases. I can press F4 to confirm that writer knows about the database and that the data is present within the database. Hovering over the field names in the writer document shows fields from the database I'm trying to use. When I select File-Print, writer displays the dialog box asking if I want to print a form letter? I select yes and then the Mail Merge dialog box opens. I select the fields I want to include in a printed report (the Records selector changes to indicate Selected Records), press OK and nothing happens. The printer select dialog never opens to select printer and printer options. Nothing happens and nothing prints.

I have also tried going through the same steps but selecting print to a file. That will open a file name dialog - but no output or file is created.

Is there something I can do to get mail merge to work again? Thanks in advance for any advice you can offer!!