Ask Your Question

Anonymous2015's profile - activity

2015-08-06 03:08:31 +0200 received badge  Famous Question (source)
2015-07-24 15:31:04 +0200 commented answer I can not use mysql connector in libo 4.4.3.2. Can not load module libmysqlcppconn.so

I don't know Doug, I always remove the Mint compiled version for the latest version of LO from the website. It has worked nice over the years since I use Linux Mint. But the solution is there and I can get to work. Thanks Doug.

2015-07-24 15:21:27 +0200 received badge  Scholar (source)
2015-07-24 15:19:21 +0200 commented answer I can not use mysql connector in libo 4.4.3.2. Can not load module libmysqlcppconn.so

By adding a correct user (non administrative) it now works! :-). Doug, for you a very special thanks for helping me sorting this out. Thank you.

2015-07-24 15:11:17 +0200 commented answer I can not use mysql connector in libo 4.4.3.2. Can not load module libmysqlcppconn.so

I have found maybe a solution to this. Kinda a workaround? This is what I did. I remembered the xml file you mentioned. I had a look at it, then I remembered some option in LO called pooling. You can find it in the settings like this: Tools -> Options -> LO base -> Connections -> Pooling. Enable it en select the mysql option set it to yes. Then save it and create a base database and connect to Mysql. I still can't login though but I get some error which means there is a connection.

2015-07-23 23:43:44 +0200 received badge  Notable Question (source)
2015-07-23 20:38:52 +0200 commented answer I can not use mysql connector in libo 4.4.3.2. Can not load module libmysqlcppconn.so

That is right. LO does rely on Java. But like Oracle's Java which causes a lot of write action to the ssd drive, which is not good for the drive. So, if I use Java then it came a long with Linux it self and not a 3rd party like Oracle.

2015-07-23 20:28:23 +0200 commented answer I can not use mysql connector in libo 4.4.3.2. Can not load module libmysqlcppconn.so

Also, I connected as root, which you must not do. The first time I got a connection but I was not allowed. After some research I came to know that you cannot login as root. So I created a user account for libreoffice and loggedin that way. Now it works in windows but not linux. I got the same error about not be able to load that library from the first post, in linux. The problem still exists.

2015-07-23 20:25:49 +0200 commented answer I can not use mysql connector in libo 4.4.3.2. Can not load module libmysqlcppconn.so

Hi Doug, I will not rely on Windows. But I have tested it. It works for now, the only thing is, not on linux. The steps I have taken are 1) in my.cnf (mysql config file) comment out bind_address = 127.0.0.1. 2) restart the server. 3) create a base database and connect to mysql. During this process the address changes. For example: if the database is located at 192.168.1.5 and you make a test connection then it will say 192.168.1.15. So, probably some coding error?

2015-07-23 18:49:25 +0200 commented answer I can not use mysql connector in libo 4.4.3.2. Can not load module libmysqlcppconn.so

Hi Doug, I already reinstalled LO. I even updated from 4.4.3.2 to 4.4.4.3. I also have a SSD installed, so I would prefer not to use java in any kind of way, especially Oracle java. I have one option left which is virtualbox. I have windows 7 installed there. I will try it. I'm using Linux Mint 17.2

2015-07-22 19:29:18 +0200 commented answer I can not use mysql connector in libo 4.4.3.2. Can not load module libmysqlcppconn.so

Hi Doug, Thanks for answering but this is not the solution. I tried it but I get "This extension 'mysql connector' will not run on this computer". I do not know which version this is but I'm using Linux. I tried that as well and got the extension I already had. I do not know if there is a new version for 4.4 (I'm using Libre Office 4.4.4.3)

2015-07-22 15:33:13 +0200 received badge  Popular Question (source)
2015-07-21 10:40:42 +0200 commented answer Is it possible to have a graphic field in Database?

No not really, at least not that I know of. As a hobby I do websites with mysql and it will probably not crash but it is still better to use links instead of the database it self. It just slows... It will cost you performance or you will need to have an very powerful server which can handle the large files (eventually it will eat your performance away).

2015-07-21 10:37:47 +0200 received badge  Editor (source)
2015-07-20 23:35:06 +0200 answered a question Is it possible to have a graphic field in Database?

Yes, this is possible as described above. However, you may need to be careful because if you save images the database becomes a large file which means it either crash or load very very slowly. I would like to advice you to use links instead.

2015-07-20 23:27:01 +0200 asked a question I can not use mysql connector in libo 4.4.3.2. Can not load module libmysqlcppconn.so

Hi there,

I would like to know how I can solve the problem of loading modules. It says it can not load modules when I create a libreoffice base database and want to connect to mysql. The exact error is:

SQL-status: 08001 Unable to load the libmysqlcppconn.so library.

Now, when I do a search the file libmysqlcppconn.so, it can not be found.

user@computer ~ $ find libmysqlcppconn.so

and

user@computer ~ $ locate libmysqlcppconn.so

Also find nothing. Then I extract the .oxt file with my file archiver and find the libmysqlcppconn.so. So can someone tell me where to put is so that I can see if this solves my problem?

It seems the extention manager from libreoffice isn't working properly.

Thanks in advance.

EDIT: It seems I have found the file I'm looking for but it is still not working. The file I found is here:

/home/user/.config/libreoffice/4/user/uno_packages/cache/uno_packages/lubwewqi.tmp_/mysql-connector-linux_4-3_x86_64.oxt/libmysqlcppconn.so

EDIT: If you have a problem like this, then you need to enable "Pooling" in the LO settings. You can find it here:

Tools --> Options --> Libreoffice Base --> Connections --> Enable pooling --> Set mysql option (org.openoffice.comp.drivers.MySQL.driver) to yes, leave the time out.

Then select OK and try it again.