Ask Your Question

MQ-818's profile - activity

2020-03-25 08:18:35 +0200 received badge  Notable Question (source)
2020-03-24 21:42:29 +0200 received badge  Popular Question (source)
2020-03-24 18:42:08 +0200 marked best answer Form Control Missing "More controls" !

Version: 6.3.5.2 (x64) Build ID: dd0751754f11728f69b42ee2af66670068624673

CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win;

Locale: en-US (en_US); UI-Language: en-US

Windows 10 Pro / 1909

I was going to add a table/Grid view in an existing form. Looking under Form Control and just found out MORE button is missing. I am not sure how to get it back. I have checked under the VIEW >> TOOLBAR >> Form Controls (Checked) and Form Design (Checked). And YES I am in the design view since I have access to buttons, spin, navigation, etc.

Your kind help is greatly appreciated.

2020-03-24 17:13:19 +0200 edited question Form Control Missing "More controls" !

Form Control Missing "MORE CONTROLs" !!! Version: 6.3.5.2 (x64) Build ID: dd0751754f11728f69b42ee2af66670068624673 CPU

2020-03-23 22:57:55 +0200 received badge  Notable Question (source)
2020-03-23 19:23:20 +0200 edited question Calling Several Sub(s) from another Sub in Base Macro --Error 91

Calling Several Sub(s) form another Sub in Base Macro --Error 91 I have several Subs (13 in total) in a module that are

2020-03-21 00:19:41 +0200 received badge  Popular Question (source)
2020-03-19 19:14:40 +0200 marked best answer Calling Several Sub(s) from another Sub in Base Macro --Error 91

I have several Subs (13 in total) in a module that are all working individually. The way they are designed to work is in sequential order.
Here is an example: Sub 1 do something, Sub 2 other thing....Sub 13 display final result

My issue is...Let's say I change some value in sub 4, Now I have to click through 5 to 13 to get the intended result. So, Now that everything is working, to make life simpler I am creating a MASTER button that will just run all the subs.

Below is a sample of one of my working sub and the master-sub (error-91)

EXACT ERROR MESSAGE: [BASIC runtime error. '91' Object variable not set]

Sub Calculate_ALL_Entries

DownPay_In_Percent

End Sub

REM....1. CALCULATE THE DOWNPAYMENT PERCENTAGE

Sub DownPay_In_Percent(oEvent as Object)

    dim oForm as Object
    dim oSubForm as Object
    dim tempP_SalesPrice as double  
    dim tempDownPay as double
    dim tempDownPay_P as double

    oForm = oEvent.Source.Model.Parent
    REM...// oForm = ThisComponent.Drawpage.Forms.getByName("subfrm_PropertyCal") 

    tempP_SalesPrice = oForm.getByName("txtP_SalesPrice").currentvalue
    tempDownPay = oForm.getByName("txtCal_DownPay").currentvalue
    tempDownPay_P = (tempDownPay / tempP_SalesPrice) * 100
    oForm.getByName("txtCal_DownPay_P").text = tempDownPay_P
    oForm.Columns.GetByName( "Cal_DownPay_P" ).updatedouble(tempDownPay_P,3) 'Use 1 to 17 here '         
            REM...//  MsgBox("Down payment % is "& tempDownPay_P)

End Sub

2020-03-04 01:40:03 +0200 received badge  Popular Question (source)
2020-03-03 22:26:12 +0200 marked best answer SAVE isn't saving the updated field (Macro Issue)

So here is the Macro....That is working!!! But fail to SAVE

After running the following macro, I can see the correct % at the form (MsgBox & Field). The field that is receiving the data back is "txtCal_DownPay_P" only part that is missing is even though the information is updated form's SAVE button still gray and I can't save it. The only way to save it is....If I go to that field and rewrite the calculated info than SAVE wakes up!! How to fix it, please!!!

Sub Call_Calculator (Event as Object)
        dim Form as Object
        dim tempP_SalesPrice as double  
        dim tempDownPay as double
        dim tempDownPay_P as double

        Form = Event.Source.Model.Parent

        tempP_SalesPrice = Form.getByName("txtP_SalesPrice").currentvalue

        tempDownPay = Form.getByName("txtCal_DownPay").currentvalue

        tempDownPay_P = tempDownPay / tempP_SalesPrice

        Form.getByName("txtCal_DownPay_P").text = tempDownPay_P

        MsgBox("Down payment % is "& tempDownPay_P)

End Sub
2020-03-03 06:34:50 +0200 edited question SAVE isn't saving the updated field (Macro Issue)

SAVE isn't saving the updated field So here is the Macro....That is working!!! But fail to SAVE After running the follo

2019-10-21 12:27:49 +0200 received badge  Notable Question (source)
2019-10-07 06:58:49 +0200 received badge  Popular Question (source)
2019-10-07 02:26:11 +0200 commented answer Split Base DB. Field is Decimal. Decimal places was 2, now it's 0??? How to fix it!!!

Got it Thanks for your help!

2019-10-07 02:11:42 +0200 commented answer Split Base DB. Field is Decimal. Decimal places was 2, now it's 0??? How to fix it!!!

I think this is where I went wrong!!! 1) I added new fields on an existing table (Not a problem) 2) My last few number

2019-10-07 01:38:17 +0200 edited answer Split Base DB. Field is Decimal. Decimal places was 2, now it's 0??? How to fix it!!!

Looks like I can use SQL command One field at a time. But if you have a better approach, please share it. Thanks! ALTER

2019-10-07 01:36:55 +0200 answered a question Split Base DB. Field is Decimal. Decimal places was 2, now it's 0??? How to fix it!!!

Looks like I can use SQL command One field at a time. But if you have a better approach, please share it. Thanks! ALTER

2019-10-07 01:34:16 +0200 edited question Split Base DB. Field is Decimal. Decimal places was 2, now it's 0??? How to fix it!!!

Split Base DB. Field is Decimal. Decimal places was 2, now it's 0??? How to fix it!!! Hi, For several years I am using

2019-10-07 01:31:48 +0200 edited answer Im having a problem with Base app. I cant get it to work. It keeps asking for JRE. I installed it from Java, but its still doesnt work.

Use Split-DB. It's very reliable. Please check UNDER: Tools >> Options >>Advanced >> Java Options //

2019-10-07 01:27:27 +0200 commented question Split Base DB. Field is Decimal. Decimal places was 2, now it's 0??? How to fix it!!!

1) DataBase Version: Version: 6.2.7.1 (x64) Build ID: 23edc44b61b830b7d749943e020e96f5a7df63bf CPU threads: 8; OS: Wind

2019-10-07 00:48:22 +0200 answered a question Im having a problem with Base app. I cant get it to work. It keeps asking for JRE. I installed it from Java, but its still doesnt work.

Use Split-DB. It's very reliable.

2019-10-07 00:41:06 +0200 asked a question Split Base DB. Field is Decimal. Decimal places was 2, now it's 0??? How to fix it!!!

Split Base DB. Field is Decimal. Decimal places was 2, now it's 0??? How to fix it!!! Hi, For several years I am using

2019-07-26 08:17:19 +0200 received badge  Self-Learner (source)
2017-09-17 16:32:44 +0200 received badge  Famous Question (source)
2016-11-17 02:27:21 +0200 commented answer Base DB opens as write document

I learned a way to connect LOBase to MySQL. (ODBC Unicode Driver)

Would it prevent me from this type of head ache? Please advice!!!

2016-11-16 21:28:09 +0200 commented question Base DB opens as write document

I don't know any backup.... Do you know where to find backup? Is there a way to setup for auto backup?

2016-11-16 21:27:20 +0200 commented answer Base DB opens as write document

Thanks for getting back. Is there any youtube video that I can follow ? or Is it possible to have (1,2,3 type) step by step easy to follow guide?

Sorry novice user here.

2016-11-16 00:25:59 +0200 received badge  Notable Question (source)
2016-11-15 08:04:35 +0200 received badge  Popular Question (source)
2016-11-14 19:51:02 +0200 asked a question Base DB opens as write document

I am so disappointed. Everything worked two days ago. Today I need some information and my BASE DB is opening as Write document. It even asked me if I would like to fix it....I choose YES. Now what? Please help me...

Version: 5.1.4.2 Build ID: f99d75f39f1c57ebdd7ffc5f42867c12031db97a CPU Threads: 2; OS Version: Windows 6.2; UI Render: default; Locale: en-US (en_US)

Thanks in advance. Monjur

2016-03-21 21:38:18 +0200 received badge  Famous Question (source)
2016-02-21 08:47:31 +0200 received badge  Famous Question (source)
2016-02-20 20:21:55 +0200 marked best answer How to create an Update query in BASE SQL

SYNTAX: UPDATE table SET column = Expression [, ...] [WHERE Expression];

UPDATE "tblMainCustInfo" SET "Cell_Phone1_Name" = 'Some text' WHERE "Cell_Phone1_Name" IS NULL

I tried this but NO GO....!!!!

Not sure how to solve this.

FYI: I am super new in SQL; so please be patient with me.

Thanks in Advance.

2016-01-08 20:51:56 +0200 received badge  Famous Question (source)
2015-10-05 01:09:48 +0200 received badge  Notable Question (source)
2015-10-05 01:09:48 +0200 received badge  Famous Question (source)
2015-09-14 10:53:22 +0200 received badge  Famous Question (source)
2015-08-18 19:08:42 +0200 marked best answer base text_date_field to Base_Date_field Update/Convertion

Hi, I have a base table, where there is valid dates (fldBirthDateOLD) but the field type is Varchar/Text. I need this field (fldBirthDateOLD)to be Date Field (fldBirthDateNEW). I am not sure how to do this, since Update SQL stop's due to data type mismatch.

I have a feeling there is something very simple that I am missing that I can add to my SQL, so TEXT date can be converted and update into the correct DATE filed.

UPDATE "tblBirthDayDetail" SET "fldBirthDateNEW" = "fldBirthDateOLD"

Thanks in advance for your kind input and teaching.

2015-06-12 22:03:58 +0200 received badge  Notable Question (source)
2015-06-12 22:03:58 +0200 received badge  Popular Question (source)
2015-06-08 08:00:51 +0200 received badge  Notable Question (source)
2015-06-08 08:00:51 +0200 received badge  Popular Question (source)
2015-05-22 03:30:21 +0200 received badge  Notable Question (source)