Ask Your Question

adam r's profile - activity

2015-08-29 21:27:19 +0200 received badge  Famous Question (source)
2014-04-02 01:26:48 +0200 received badge  Popular Question (source)
2014-04-02 01:26:48 +0200 received badge  Notable Question (source)
2014-02-09 18:27:03 +0200 commented question How to choose delimiter for CSV?

This is basically a dup of http://ask.libreoffice.org/en/question/23332/csv-files-lose-formatting-after-save/?answer=29621#post-id-29621 . I tried to close but could not. I contributed my description as an answer to the other question. I think my question/title is more explicit about the nature of the problem and would therefore be easier to find.

2014-02-09 18:23:54 +0200 answered a question CSV files lose formatting after save.

There is some complicated behavior related to this. Here's what I've identified on my system (4.1.4.2-4.fc19 on Fedora). You should be able to get the results you want using the following description, but it is clumsy and non-intuitive.

First, here's the official description: https://help.libreoffice.org/Calc/Importing_and_Exporting_CSV_Files

In my experience, the first time I save a file as CSV, I am given the "Export Text File" prompt, and I can select whatever delimiter I want (confirmed with gEdit). However, if I open the file to edit it, I do not see that prompt the next time that I save. For subsequent saves, tabs are used, even if I had used commas originally.

I think this may be connected to the "Text Import" dialog choices. If I import the text with multiple delimiters selected, then the next time it is saved with tabs. However, if I deselect the non-comma delimiters, then it saves with comma delimiters. My impression is that the default is to import with comma, tabs, and semicolons as delimiters.

If I want to specify the delimiters (again), I've found that I can select the "Edit Filter Settings" checkbox on the save dialog. After clicking OK and then confirming that I do really want to save the file with the selected name and format, the "Export Text File" prompt will show up again. My guess is that this is the recommended way to select the delimiter, though I found this to be non-intuitive and clumsy.

2014-02-09 18:20:08 +0200 asked a question How to choose delimiter for CSV?

What is the recommended way to choose the delimiter used for CSV export with LO Calc?

My problem is that my spreadsheet is being saved with tab delimiters while my downstream program expects comma-delimiters. This seems to have somehow become the default for my file, which is non-intuitive behavior for a "comma separated file". This may be a bug. I am using build 4.1.4.2-4.fc19 on Fedora.

Here's the behavior that I've identified, but they do not suggest a straight-forward way of handling this issue:

First, here's the official description: https://help.libreoffice.org/Calc/Importing_and_Exporting_CSV_Files

In my experience, the first time I save a file as CSV, I am given the "Export Text File" prompt, and I can select whatever delimiter I want (confirmed with gEdit). However, if I open the file to edit it, I do not see that prompt the next time that I save. For subsequent saves, tabs are used, even if I had used commas originally.

I think this may be connected to the "Text Import" dialog choices. If I import the text with multiple delimiters selected, then the next time it is saved with tabs. However, if I deselect the non-comma delimiters, then it saves with comma delimiters. My impression is that the default is to import with comma, tabs, and semicolons as delimiters.

If I want to specify the delimiters (again), I've found that I can select the "Edit Filter Settings" checkbox on the save dialog. After clicking OK and then confirming that I do really want to save the file with the selected name and format, the "Export Text File" prompt will show up again. My guess is that this is the recommended way to select the delimiter, though I found this to be non-intuitive and clumsy.

Is there a better (more convenient) way? Is this a bug?

thanks in advance.