We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question

JGL's profile - activity

2021-04-30 20:29:34 +0200 asked a question How to refresh text rendering after executing a macro ?

How to refresh text rendering after executing a macro ? Hello everyone, Background - I have a document with multiple sh

2021-04-16 01:15:47 +0200 received badge  Notable Question (source)
2021-04-16 00:45:00 +0200 received badge  Self-Learner (source)
2021-04-16 00:45:00 +0200 received badge  Teacher (source)
2021-04-15 16:57:25 +0200 answered a question Unordered numbering for tags

Just to put a cap on this post, I ended up facing my fears (XD) and wrote a macro that inserts a numbered tag [(1), (2),

2021-04-13 21:39:44 +0200 received badge  Popular Question (source)
2021-04-13 17:14:05 +0200 received badge  Enthusiast
2021-04-12 21:07:51 +0200 commented question Unordered numbering for tags

Thanks a lot for your input, I appreciate. It would indeed solve the problem, but it would make the tag IDs very long an

2021-04-12 20:47:22 +0200 received badge  Famous Question (source)
2021-04-12 20:47:22 +0200 received badge  Notable Question (source)
2021-04-12 20:46:53 +0200 received badge  Notable Question (source)
2021-04-12 20:45:52 +0200 asked a question Unordered numbering for tags

Unordered number in headings as reference Hello everyone ! I am looking for a way to automatically insert numbered tag

2020-12-09 08:34:17 +0200 received badge  Popular Question (source)
2020-12-08 19:12:36 +0200 received badge  Supporter (source)
2020-12-08 19:12:14 +0200 marked best answer Sideheads shown at an incorrect level in the navigator

Hello everyone, please see the following sample document. Using LO 7.0.1.2

I would like to put my level 4 headings in the margin, aligned with the top of the paragraph they are anchored to. I am using frames with a custom frame style "Sidehead frame" and one of the default paragraph styles "Heading 4".

In the navigator, I would expect those level 4 headings to appear under level 3 items, however they remain at the very top of the tree.

You can also see that a standard level 4 heading inserted in the text instead of in a frame appears at the expected location in the tree, as shown in the following picture.

image description

When exporting to PDF, bookmarks are "mixed up" in the same way. Is there any setting I should tweak to get this working as expected or is it the software's intended behavior, or maybe a bug ?

Thanks ! :)

2020-12-08 19:11:41 +0200 commented answer Sideheads shown at an incorrect level in the navigator

Thank you so much for the detailed explanations. You second suggestion allows me to get exactly what I want, even though

2020-12-08 17:37:40 +0200 received badge  Editor (source)
2020-12-08 17:36:27 +0200 asked a question Sideheads shown at an incorrect level in the navigator

Sideheads shown at an incorrect level in the navigator Hello everyone, please see the following sample document. I woul

2020-12-03 01:08:05 +0200 received badge  Popular Question (source)
2020-12-02 19:37:43 +0200 marked best answer Misplaced cross-reference/table of contents links when exporting to PDF

Hello everyone,

I have a Writer document containing a table of contents and cross-references to headings. In Writer, those elements can be clicked as links to the page/heading they refer to.

When exporting to PDF, I would expect the above mentionned elements to behave the same. But, when opening the PDF using a viewer such as Adobe Acrobat Reader DC or Mac OS Preview, the clickable area of the link is severely misplaced relative to the word(s).

image description

The picture above shows a PDF export of a document containing "Please refer to Heading 1.2.1." where Heading 1.2.1 is a cross-reference link to the related heading. The words "Heading 1.2.1" themselves can't be clicked, as the clickable area is found elsewehere (i.e. at the very top of the page, as shown by the black rectangle and hand-shaped mouse cursor).

Something similar happens with the table of contents :

image description

Would that be a known issue, is there something I could be doing wrong? Using both 6.4.7.2 and 7.0.1.2 versions of LibreOffice on MacOS 10.15.7.

Thanks for your help !

2020-12-02 19:37:43 +0200 received badge  Scholar (source)
2020-12-02 18:49:29 +0200 commented question Misplaced cross-reference/table of contents links when exporting to PDF

It seems to be related to the settings, as restarting the application in safe mode and reseting my user profile solved t

2020-12-02 18:15:46 +0200 commented question Misplaced cross-reference/table of contents links when exporting to PDF

I used a Win 10 PC with LO 7.0.3.1 to export to PDF and it works as intended.

2020-12-02 17:06:15 +0200 asked a question Misplaced cross-reference/table of contents links when exporting to PDF

Misplaced cross-reference/table of contents links when exporting to PDF Hello everyone, I have a Writer document contai