Haz tu Pregunta
0

Como puedo usar la funcion if (si) con horas

preguntado 2018-08-04 22:08:21 +0200

Imagen Gravatar de Phildiujj

quisiera hacer una formula automatica que me diera la diferencia de horas de una celda si supera la cantidad de horas semanales por ejemplo 47 horas sobre 45, y si no que solo me salga 0 o 0:00, he probado con =SI(A16>45; A16-45; 0) , en la casilla A16 el formato es 45:00:00

Gracias de antemano.

edit re-etiquetar marcar como ofensivo cerrar fusionar delete

1 Responder

Ordenar por » viejos nuevas más votado
1

respondido 2018-08-06 23:45:11 +0200

Imagen Gravatar de m.a.riosv

Antes de todo hay que entender como los valores de fecha/hora son almacenados en las celdas, con independencia del formato que se utilice para visualizarlos.
Un día es = 1
una horas es = 1/24
Si en una celda hay 45:00:00 su valor decimal debe ser = 1/24*45 = 1,875
El formato de la celda debe ser [HH]:MM:SS para que se vea como 45:00:00, los corchetes hacen que se visualice la suma de las horas en lugar de la hora del día que representa.

=SI(A16>(1/24*45);A16-(1/24*45);0) debería funcionarte.

https://help.libreoffice.org/6.2/es/t...

edit marcar como ofensivo delete enlace mas

Comments

Gracias funciono a la perfeccion...

Imagen Gravatar de Phildiujj Phildiujj ( 2018-08-12 23:12:57 +0200 )edit
Ingresa/Regístrate para Contestar

Herramientas de Preguntas

1 seguidor

Estadisticas

Preguntado: 2018-08-04 22:08:21 +0200

Visto: 78 veces

Ultima actualización: Aug 06 '18