Poser votre question
1

[calc] erreur dans formule somme

posée 2018-11-16 22:28:14 +0200

Image Gravatar de larry3460

Bonjour, j'utilise une formule simple :

=SOMME(AR42:CG42)

son résultat est faux. Elle renvoie 0 alors qu'il y a un chiffre 1 dans la ligne. S'agirait-il d'un bug ?

éditer requalifier signaler fermer fusionner supprimer

3Réponses

1

répondue 2018-11-17 16:32:16 +0200

Image Gravatar de Headwar

Bonjour,

Il est possible que ce "1" soit le caractère "1" et non un nombre du point de vue de LO. Ca arrive quand on importe des données, LO convertit le 1 en '1 (apostrophe), qui fige le format chaîne de caractères. Essayez de remplacer ce 1 en le retapant manuellement ou même en mettant "=1".

Sinon, pas d'idée... Peut être qu'en mettant à dispo le fichier (après l'avoir vidé des données confidentielles), ca aidera ?

Cdt

éditer signaler supprimer permalien plus

Commentaires

Je viens de faire le test sous Calc 6.3 car j'ai eu la surprise sur Excel cette semaine. Les tableurs ne distinguent plus les nombres et les nombres stockés en texte. Il les calcule. Hérésie à mon sens.

Image Gravatar de MarieJoMarieJo ( 2018-11-25 00:03:46 +0200 )éditer
1

répondue 2018-11-24 23:59:24 +0200

Image Gravatar de MarieJo

Bonsoir

Vérifier quand même dans Données/calculer

que la fonctionnalité "calculer automatiquement" soit cochée

Marie-Jo

éditer signaler supprimer permalien plus

Commentaires

1

si quelqu'un sait comment cette option change de statut, je suis preneuse. C'est aléatoire et certainement provoqué par un raccourci clavier involontaire. J'en ai essayé quelques uns sans succès. Mais ce problème est récurent sur Calc. marie jo

Image Gravatar de MarieJoMarieJo ( 2018-11-25 00:00:57 +0200 )éditer
0

répondue 2018-11-19 18:45:43 +0200

Image Gravatar de larry3460

Bonjour, merci pour cette réponse. Le problème s'est résolu "très mystérieusement" de manière spontanée. En ouvrant Calc, le lendemain, les formules de somme, en bout de lignes, avaient retrouvé leur efficacité. Le mystère demeure ma, du coup, ma question est résolue. Cdt.

éditer signaler supprimer permalien plus
S'identifier/S'inscrire pour répondre

Outils de question

1 suiveurs

Stats

Posée: 2018-11-16 22:28:14 +0200

Consultée: 122 fois

Mise à jour: Nov 24 '18