Poser votre question
0

Sous Calc, comment écrire une formule définissant la présence d'une date comme une équivalence à la valeur 1 ?

posée 2018-12-04 21:58:00 +0200

ce message est marqué comme un wiki communautaire

Cette contribution est un wiki. N'importe qui ayant une aura > 75 est invité à l'améliorer.

Dans mes calculs de statistiques, j'ai besoin dans une formule de calcul, type Si, dire si la cellule correspond à une date, alors, résultat 1 si vrai et 0 si faux ? J'ai vraiment besoin d'aide car ne n'arrive pas à définir cela!!!!! aidez moi

éditer requalifier signaler fermer fusionner supprimer

2Réponses

1

répondue 2018-12-18 18:55:45 +0200

Image Gravatar de Vadakin

Bonjour, À priori ce n'est pas possible car la date est un nombre comme un autre pour Calc, c'est le formatage qui fait la différence. Mais voici une formule pour contourner le problème, trouvée sur un vieux forum :

=SI(ESTERREUR(DATEVAL(TEXTE(A1;"jj/mm/aa")));0;1)

La formule transforme le contenu de A1 en texte puis le retransforme en date. Si le contenu n'est pas une date cela provoque une erreur et affiche un 0.

éditer signaler supprimer permalien plus
1

répondue 2018-12-05 08:31:10 +0200

Image Gravatar de ajlittoz

Il y a bien la fonction DATEVALUE() mais elle traite uniquement la chaîne passée directement comme argument (on ne peut pas utiliser une référence à une cellule!). Le résultat est un entier si la chaîne est une date et Err:502 sinon.

Compte tenu de cette difficulté, pourquoi n'éclateriez-vous pas votre date dans 3 cellules: JJ, MM et (AA)AA ? Vous faites vos tests séparément sur chaque composante de la date. Cela met en jeu plus de cellules, mais c'est probablement plus simple et plus fiable.

PS: ne postez pas en wiki (votre question est personnelle, pas "générale" ou "philosophique") car cela vous empêche de gagner des points de karma nécessaires pour accéder aux fonctions "sympathiques" de ce site.

éditer signaler supprimer permalien plus
S'identifier/S'inscrire pour répondre

Outils de question

1 suiveurs

Stats

Posée: 2018-12-04 21:58:00 +0200

Consultée: 78 fois

Mise à jour: Dec 27 '18