Poser votre question
0

Afficher le N° de semaine [fermée]

posée 2018-12-27 20:12:51 +0200

ce message est marqué comme un wiki communautaire

Cette contribution est un wiki. N'importe qui ayant une aura > 75 est invité à l'améliorer.

Bonjour à la communauté, Je souhaiterais affiché les N° de semaine sur mon planning mais je n'y arrive pas sous calc.

Je précise que dans ma formule, je vais chercher la date qui est dans une cellule contenant un lien qui va elle-même chercher la date dans un autre fichier.

Et comment faire pour que ce numéro n'apparaisse que les mercredi par exemple ?

Merci pour votre aide, Sébastien.

éditer requalifier signaler réouvrir fusionner supprimer

Fermé pour la raison suivante la question est résolue, une bonne réponse a été acceptée par wget
date de clôture 2019-01-01 17:44:56.116403

Commentaires

1

Bonjour,

la fonction NO.SEMAINE() est supposée faire ça. Peut-on voir votre formule qui ne marche pas ?

Image Gravatar de jfnjfn ( 2018-12-27 20:29:43 +0200 )éditer

Bonjour jfn, voici mes formules : =SI(ET(JOURSEM($C11;2)=1;EST.IMPAIR(LIGNE()));NO.SEMAINE.ISO(C11);"") <= pour une cellule impaire ou =SI(ET(JOURSEM($C18;2)=1;EST.PAIR(LIGNE()));NO.SEMAINE.ISO(C18);"") <= pour une cellule pair.

Cela fonctionne les lundi mais pas les mercredi.

Image Gravatar de Taxou81Taxou81 ( 2018-12-27 21:03:11 +0200 )éditer

1Réponse

0

répondue 2018-12-27 20:31:40 +0200

Image Gravatar de wget

updated 2018-12-28 12:06:37 +0200

Une formule de ce type devrait faire l'affaire :

Si utilisation francisée des fonctions :

=SI(JOURSEM(B2;2)=3;NO.SEMAINE(B2;1);"")

Si utilisation anglaise des fonctions :

=IF(WEEKDAY(B2;2)=3;WEEKNUM(B2;1);"")

description de l'image

éditer signaler supprimer permalien plus

Commentaires

1

Bonjour et merci wget

Mon planning change les jours automatiquement en fonction de la date. Est ce que ta formule fait apparaitre les N° de semaine que les mercredi ? Je ne peux pas essayer ta formule car mon fichier calc, il ne prend pas le format anglais de tes formules.

J'ai trouvé une solution : =SI(JOURSEM($C5;2)=3;NO.SEMAINE.ISO(C5);"")

Merci pour votre temps, Sébastien.

Image Gravatar de Taxou81Taxou81 ( 2018-12-27 21:08:09 +0200 )éditer

@Taxou81, oui elle tient compte de cette demande. Par mesure de facilité, je n'utilise jamais les formules en français. Pour activer l'utilisation des formules anglaises, il suffit d'aller dans Outils>Options... > LibreOffice Calc > Formule> Utiliser les noms de fonction anglais.

Ma fonction traduite c'est =SI(JOURSEM(B2;2)=3;NO.SEMAINE(B2;1);"").

J'ai mis à jour ma réponse en conséquence.

Image Gravatar de wgetwget ( 2018-12-28 11:58:59 +0200 )éditer

Dire "j'ai trouvé une solution" sans mentionner où on vous l'a donné, c'est limite : https://forum.openoffice.org/fr/forum...

Image Gravatar de ValioudValioud ( 2018-12-28 12:29:00 +0200 )éditer

En effet. :) Pour les futurs lecteurs, Valioud parlait bien du commentaire de Taxou81 :)

Image Gravatar de wgetwget ( 2018-12-28 12:37:35 +0200 )éditer
1

Bonjour,

@Valioud : Oui j'ai trouvé la solution ailleurs mais je ne pensais pas que je devais donner le lien d'un autre forum. Si je te suis Valioud, je dois donc donner les références du livre que j'ai lu, ou le nom de la personne qui m'a instruite, (etc ) à toutes les réponses que je dirais dans ma vie ? Il ne faut pas abuser non plus.

@wget : Merci de ton temps, de ton aide et de ta traduction. Bon réveillon :)

Image Gravatar de Taxou81Taxou81 ( 2018-12-31 09:19:00 +0200 )éditer

N'inversez pas les rôles.

C'est bien s'attribuer le travail des autres qui est abuser.

Image Gravatar de ValioudValioud ( 2018-12-31 14:30:35 +0200 )éditer
1

Si vous lisez mon post sur le forum de LibreOffice, ou même ici, je remercie l'aide des personnes et les formules données. Je ne m'approprie absolument rien du tout. Il ne faut pas voir le mal partout. La prochaine fois, je mettrais : "J'ai trouvé une solution ailleurs..." pour satisfaire votre ego de spécialiste calc. Je sais que j'ai une connaissance limitée du logiciel donc l'aide donnée est appréciable. Loin de moi l'idée de prendre le travail des autres. Erreur de formulation. Fin de la discussion.

Image Gravatar de Taxou81Taxou81 ( 2018-12-31 15:01:33 +0200 )éditer

Outils de question

1 suiveurs

Stats

Posée: 2018-12-27 20:12:51 +0200

Consultée: 49 fois

Mise à jour: Dec 31 '18