Poser votre question
0

Problème base de données bibliographique

posée 2019-01-03 11:11:08 +0200

Image Gravatar de BarbeNoire

Bonjour, j'utilise libreoffice 6.1. Je rédige actuellement mon mémoire et j'aime remplir la base de données bibliographiques. Cependant la table 'biblio' comporte 31 champs et pour chaque entrée que je voudrais ajouter on m'exige de spécifier ces 31 champs. j'aimerais pouvoir m'en tirer en reseignant juste des champs tels ques 'abrégé, autheur, titre, pages, année,'. Comment désactiver les autres champs qui ne me sont pas utiles de manière à ne pas être obligé de les renséigner:description de l'image

Cette image contient le message d'erreur que j'obtiens lorsque je ne renseigne pas tous les champs. Par exemple je ne souhaite pas utiliser le champ 'address' dans ma bibliographie. Comment faire pour l'eclure?

éditer requalifier signaler fermer fusionner supprimer

Commentaires

Ma machine de productiion est sous LO 6.0.6.2 en Linux/Fedora 29. Aucun des champs ne sont obligatoires.

Je clique d'abord sur le première ligne libre dans la feuille du haut. Ensuite je remplis quelques champs, puis je clique de nouveau dans la feuille du haut pour valider ma saisie. J'ai vérifié que la nouvelle entrée est bien prise en compte en l'insérant dans le texte.

Comment validez-vous votre entrée pour obtenir le message?

Image Gravatar de ajlittozajlittoz ( 2019-01-03 17:37:41 +0200 )éditer

Bonjour. Pour valider une ligne je clique juste sur la ligne suivante. Cad lorsque je suis en train de remplir les champs correspondant à une ligne, je clique sur la ligne suivante pour valider mar saisie

Image Gravatar de BarbeNoireBarbeNoire ( 2019-01-04 08:41:31 +0200 )éditer

C'est la procédure normale.

Comme vous en êtes au début de saisie, essayez de tout effacer (la bibliographie, pas le document), de sauvegarder et de rouvrir le document. Ajoutez alors une entrée.

Si l'anomalie se reproduit, créez une bibliographie dans un document vierge pour confirmer que ce n'est pas lié au fichier en cours.

D'après la capture d'écran, vous êtes sous Ubuntu?

Image Gravatar de ajlittozajlittoz ( 2019-01-04 09:04:01 +0200 )éditer

oui. Je suis sous ubuntu. L'effacement de la bibliographie est la première chose que j'ai faite justement. Par la suite j'ai ouvert carrément un document vierge, puis j'ai essayé de peupler la table bibliographique avec des entrées. Le même résultat

Image Gravatar de BarbeNoireBarbeNoire ( 2019-01-04 09:09:58 +0200 )éditer

Il existe un deuxième mode, peut-être moins pratique, mais ça permet de contourner le problème: la bibliographie interne au document (au lieu d'utiliser une BdD accédée par la composant Base).

La saisie se fait par Insérer>Index & Tables>Entrée biblio (ou équivalent, mon UI n'est pas en français) en cliquant sur le bouton radio From document content puis sur le bouton Nouveau pour chaque entrée. En fin de saisie, si vous ne voulez pas insérer d'entrée, appuyez sur Annuler.

Si c'est bon, je transformerai ce commentaire en réponse.

Image Gravatar de ajlittozajlittoz ( 2019-01-04 09:19:29 +0200 )éditer

Apparement ca résoud le problème. Merci beaucoup. Une petite précision. Si je comprend bien est ce à dire que les entrées bibliograpiques ajoutées seront accessibles uniquement depuis le document à partir duquel elles sont ajoutées?

Image Gravatar de BarbeNoireBarbeNoire ( 2019-01-04 10:25:32 +0200 )éditer
1

Oui. C'est un pis-aller pour permettre d'avancer le travail. L'intérêt est d'avoir des bibliographies privées de document (plus petites donc plus facilement gérables). L'inconvénient est justement de ne pas pouvoir les partager entre documents.

En y repensant, Address est le premier champ par ordre alphabétique. Avez-vous installé le composant Base de LO? En général, les distros permettent de saucissonner (pardon, personnaliser ou "optimiser") la configuration en ne chargeant que ce qui est nécessaire. La bibliographie "générique" est gérée par Base d'où sa nécessité et peut-être aussi une machine Java. Vérifiez avec votre gestionnaire de paquets.

Pour confirmer mon intuition, renseignez Address avec n'importe quoi et voyez si l'erreur se reproduit avec le champ suivant par ordre alphabétique.

Image Gravatar de ajlittozajlittoz ( 2019-01-04 10:47:19 +0200 )éditer

Je confirme que la bibliographie "standard" est gérée par Base. Elle se trouve dans ~/.config/libreoffice/4/user/database/biblio.odb (chemin valable sous Fedora, pouvant varier avec les autres distributions; sa définition est disponible par Outils>Options, LibreOffice Base>Base de données). En conséquence de quoi, la présence du composant Base est impérative.

Image Gravatar de ajlittozajlittoz ( 2019-01-04 13:15:58 +0200 )éditer

1Réponse

0

répondue 2019-01-04 12:17:26 +0200

Image Gravatar de wget

updated 2019-01-04 13:16:52 +0200

Rappelons pour les utilisateurs lisant ce fil que:

  • La base de données bibliographique qui est partagée entre tous les documents LibreOffice est atteignable via Outils > Base de données bibliographique
  • Pour insérer une entrée provenant de cette base : aller dans Insertion > Table des matières et index > Entrée de bibliographie..., s'assurer que la case à cocher A partir de la base de données bibliographique de la section Entrée est cochée, sélectionner l'entrée correspondante identifiée par son identifiant abbrégé à partir du menu déroulant et cliquer sur la bouton Insertion. insérer une entrée bibliographique

Sous LibreOffice 6.1.4 (Arch Linux), je confirme que la méthode décrite par BarbeNoire à savoir: cliquer sur la ligne identifiée par le petit +, compléter les lignes que l'on souhaite (pas toutes donc) et valider en cliquant en dehors de cette ligne fonctionne. édition base de données bibliographique

éditer signaler supprimer permalien plus
S'identifier/S'inscrire pour répondre

Outils de question

1 suiveurs

Stats

Posée: 2019-01-03 11:11:08 +0200

Consultée: 92 fois

Mise à jour: Jan 04