Poser votre question
0

[résolu] Intégration d'une vidéo dans Impress

posée 2019-01-16 10:41:23 +0200

ce message est marqué comme un wiki communautaire

Cette contribution est un wiki. N'importe qui ayant une aura > 75 est invité à l'améliorer.

Bonjour ma question est simple: Dans Impress, comment intégrer une vidéo dans un des slides de la présentation ? Il y a manifestement un problème, ça bug à toutes mes tentatives et ce, malgré l'utilisation de formats vidéo libres... Depuis plusieurs jours, je sonde en vain le web pour trouver une réponse... J'ai bien trouvé quelques pistes où on utilise un hyperlien... mais bon ... c'est quand même pas très pro :s

Une vidéo dans un slide me semble une des bases... Je suis un fervent défenseur du Libre mais ici je n'ai aucun argument à avancer à mes détracteurs.

Merci beaucoup et bonne journée

éditer requalifier signaler fermer fusionner supprimer

Commentaires

"ça bug" n'aide pas à comprendre ce qui vous arrive.

Pourquoi ne pas fournir une procédure pas-à-pas et illustrée par des copies écran ?

Dans ce lien, il y a une vidéo pour faire un test : https://forum.openoffice.org/fr/forum...

Image Gravatar de ValioudValioud ( 2019-01-17 20:20:26 +0200 )éditer

Merci pour vos retours, Je suis sur ubuntu 18.04 libreoffice 6.1. Le "bug" est le suivant : où la vidéo devrait se lancer,nous n'avons que :

  • le son quand il s'agit d'un fichier .ogv par ex
  • une image figée lorsqu'il s'agit d'un mp4

Je tiens à préciser que les deux fichiers sont lus sans problème par VLC. Par acquis de conscience, j'ai désinstallé et réinstallé L O. Même résultat... Un de mes collègues est confronté au même problème.

Dans des versions précédentes, je ne me souviens pas avoir eu ce type de souci, on insérait la vidéo ensuite elle était lue lors du diaporama automatiquement ou au clic selon la demande.

Merci d'avance pour vos précieux conseils

Image Gravatar de nymalkanymalka ( 2019-01-24 16:25:49 +0200 )éditer

@nymalka Je viens de mettre à jour ma réponse en conséquence basée sur votre commentaire. :)

Image Gravatar de wgetwget ( 2019-02-16 17:08:47 +0200 )éditer

2Réponses

0

répondue 2019-01-18 19:24:49 +0200

Image Gravatar de wget

updated 2019-02-16 17:08:24 +0200

Le lien évoqué par Vallioud est quelque peu périmé, car il mentionne la Java Media Foundation. LibreOffice n'utilisant plus de Java (excepté dans quelques extensions encore et dans les drivers de base de données de base), je vous invite à prendre connaissance de cette question pour savoir quels framework LibreOffice utilise pour les vidéos et le son, en fonction du système d'exploitation.

Aussi, pouvez-vous préciser votre système d'exploitation? Vous précisez utiliser du libre, utilisez-vous GNU/Linux, si oui, quelle distribution et version de distribution?

Tests effectués :

  • De mon côté, je n'ai pas de problème particuliers sous Windows.

  • Cependant, j'ai toujours des problèmes sous Arch Linux où là, je n'ai aucune vidéo qui se lit, je pense qu'il s'agisse d'un problème spécifique à Arch vu que tout le code de LibreOffice n'est pas intégré, il se peut qu'il y ait des fonctionnalités qui ne fonctionnent pas. J'ai reporté un bug à ce sujet.

  • Sous ma VM macOS 10.14, j'ai des problèmes également. Mais je pense que c'est dû au fait qu'il s'agit d'une VM et que tout ce qui est graphique est instable (je ne sais pas lire une vidéo même sans VLC sans que ça échoue). Safari et Youtube, ça va, étonnamment, mais tout ce qui est local échoue.

EDIT 2019-02-16:

Je viens de tester sur un Ubuntu 18.10 avec LibreOffice 6.1.3 et je n'arrive pas à reproduire les 2 problèmes cités à la fois avec une vidéo OGV et MP4. J'ai utilisé les vidéos d'exemple disponibles à cette adresse.

éditer signaler supprimer permalien plus

Commentaires

En quoi ce que je donne est-il périmé ? Il comporte une vidéo de test et des liens vers des packs de codec à télécharger.

Je trouve qu'en plus déclarer sa propre réponse comme correcte alors que l'auteur n'est jamais revenu donner suite est un peu facile.

Image Gravatar de ValioudValioud ( 2019-02-18 12:10:32 +0200 )éditer
0

répondue 2019-05-16 14:34:17 +0200

Image Gravatar de nymalka

updated 2019-05-16 14:36:06 +0200

Hello, l'auteur revient donner suite :) Les différentes pistes qui avait été données à l'époque ne m'avaient pas permis de trouver une solution (je m'y étais peut-être mal pris ou avait mal compris quelques chose).

Ceci dit, mon collègue qui n'a jamais laché l'affaire a finalement trouvé une solution. En installant une bibliothèque que nous n'avions pas sur nos systèmes et manifestement pas installée par libreOffice, tout fonctionne !!! C'était peut-être tellement évident qu'on est passé à côté ? En tout cas, pour les autres néophytes, voici la ligne de commande que nous avons utilisé:

sudo apt install libreoffice-avmedia-backend-gstreamer

Dans tout les cas, merci de votre intérêt pour la question ;)

éditer signaler supprimer permalien plus
S'identifier/S'inscrire pour répondre

Outils de question

1 suiveurs

Stats

Posée: 2019-01-16 10:41:23 +0200

Consultée: 78 fois

Mise à jour: May 16