Poser votre question
0

formats texte iso 1252 et UTF-8

posée 2019-03-06 20:55:41 +0200

Image Gravatar de enigma158an201

updated 2019-03-06 21:22:22 +0200

Bonjour,

lorsque que je telecharge sur le site de ma banque (CA) les relevés de compte (format slk, ou équivalent csv apparemment), et que j'importe le fichier sur calc, je constate un problème avec les caractères accentués

je suppose que le fichier téléchargé est au format iso 1252, car il s'ouvre bien avec calc sous windows, mais lorsque j'ouvre le même document sous la version linux: Version: 5.1.6.2 Build ID: 1:5.1.6~rc2-0ubuntu1~xenial6 Threads CPU : 4; Version de l'OS :Linux 4.15; UI Render : par défaut; Locale : fr-FR (fr_FR.UTF-8); Calc: group

j'ai des caractères de ce type � à la place des é

quelqu'un aurait t il une idée pour préparer le fichier ou le convertir à la volée lors de l'importation? - j'ai cru comprendre qu'il existe un application recode sous linux, mais je ne maîtrise pas vraiment ou - je cherche un moyen d'indiquer le format lors de l'importation du fichier mais je bloque sur une solution

edit: j'ai trouvé un debut de solution sur le site ubuntu le fichier est finalement du windows-1252 du coup si une solution utilise un script, ou une idée via les macros open office, alors je suis vraiment preneur je regarde du coté de gedit pour commencer

merci pour votre aide

éditer requalifier signaler fermer fusionner supprimer

3Réponses

0

répondue 2019-03-10 00:07:11 +0200

Image Gravatar de Sébastien C.

updated 2019-03-13 05:03:47 +0200

Bonjour à tous,

Je suis surpris qu’à l’import, en ouverture depuis Calc (et bien entendu sous Linux), il ne vous soit pas demandé de préciser vous-même l’encodage pour du CSV dans la boite de dialogue idoine

Import CSV

La macro suivante devrait vous aider :

Sub ouvrirCSV
 Dim monFichierCSV As String
 Dim mesOptions(2) As New com.sun.star.beans.PropertyValue

 monFichierCSV = "/home/VOUS-MEME/la/où/se/trouve/le/fichier.csv"

 ' Ouvre le fichier CSV.'
 mesOptions(0).Name = "FilterName"    : mesOptions(0).value = "Text - txt - csv (StarCalc)"
 mesOptions(1).Name = "FilterOptions" : mesOptions(1).value = "44,34,ANSI,1"
 '   44 =       Séparateur de champs : virgule.'
 '   34 = Délimiteur de champs texte : caractère de guillemets ".'
 ' ANSI =                   Encodage : Europe occidentale (Windows-1252/WinLatin1).'
 '    1 =   Première ligne à traiter : ligne 1 (donc, PAS de ligne de titre).'

 monDocumentCSV = starDesktop.loadComponentFromURL(convertToURL(monFichierCSV), "_blank", 0, mesOptions())
End Sub

À l’import par macro, il est aussi possible de définir la caractéristique des colonnes (Standard / Texte / Date / ne pas prendre en compte). C’est un peu compliqué à mettre en place mais une fois compris, très efficace.

Je reste à votre disposition pour vous en expliquer/dévellopper un peu plus si nécessaire.

:-)

éditer signaler supprimer permalien plus
0

répondue 2019-03-10 13:48:36 +0200

Image Gravatar de enigma158an201

Bonjour et merci pour vos réponses,

je n'ai pas encore testé vos propositions par manque de temps, je pourrai en dire plus d'ici ce soir

pour le moment j'ai constaté que la version sous Windows Seven ou je suis en libre office V6 et celle que j'ai sous mint 18.3 en v5 ne se comportent pas tout à fait de la même façon à l'ouverture d'un fichier de type texte et que l'extension du fichier joue pour beaucoup dans l'affichage du menu d'importation qui permet de choisir le codage

mais cela dit il serait intéressant de pouvoir travailler avec la meme version sur les deux OS

je vais commencer par trouver un moyen de mettre à jour la v5 sous mint, et ensuite je testerai cette macro qui permet d'ouvrir un CSV pour ce qui est des options par défaut, je ne souhaite pas revenir dessus pour le moment

Cordialement

éditer signaler supprimer permalien plus
0

répondue 2019-03-06 23:25:40 +0200

Image Gravatar de Michel Rudelle

Bonjour,

J'ai rencontré ce problème quand je suis passé à Linux, le jeu de caractère sélectionné dans l’assistant d'importation n'était pas le bon (je ne me souviens plus lequel était affiché, probablement UTF-8). Je l'ai changé pour Europe occidentale (Windows-1252/WinLatin 1) et depuis tout va bien, l'assistant conserve ce choix.

Si vous utilisez une macro pour ouvrir ces fichiers, il faut utiliser ANSI pour le filtre d'import.

Cordialement,

éditer signaler supprimer permalien plus
S'identifier/S'inscrire pour répondre

Outils de question

3 suiveurs

Stats

Posée: 2019-03-06 20:55:41 +0200

Consultée: 49 fois

Mise à jour: Mar 13