Poser votre question
0

Les liens hyperliens ne fonctionne plus sur Calc depuis les derniéres mises à jour

posée 2019-03-13 18:47:31 +0200

Image Gravatar de JakGill

updated 2019-03-18 17:38:14 +0200

J'ai noté que systématiquement un blanc est rajouté en fin de lien, donc il ne marche pas. Je parle de lien vers un site Internet. Avant ces liens fonctionnaient bien en appuyant sur CTRL et en pointant sur la cellule. Maintenant, j'ai un message d'erreur et le lien a en plus %00

Je suis obligé de couper le lien de la cellule, et de le recopier dans la même cellule et alors cela marche! Avez vous la solution pour que cela fonctionne sans cette manip? Merci pour votre aide JGC:\fakepath\TestHyperl.xls

éditer requalifier signaler fermer fusionner supprimer

Commentaires

Bonjour

Pourrais-tu préciser ton environnement (versions système & LibreOffice) de manière à restreindre la recherche dans la liste des bugs et tenter de reproduire le problème. Un exemple de classeur (expurgé de données personnelles) comprenant un tel dysfonctionnement serait utile...

Cordialement

Image Gravatar de pierre-yves samynpierre-yves samyn ( 2019-03-16 08:54:11 +0200 )éditer

Suite à votre demande de précision, je vous joins un fichier expliquant le pb. Je suis sous Win 10 avec les dernières mises à jour. La version de Calc est celle de 6.2.1, mais cela avait commencé avec la 6.2.0 et 6.1.3 Merci pour votre aide

Jak

PS: j'ai un fichier Calc avec ce pb, mais comment puis je le joindre??? merci

Image Gravatar de JakGillJakGill ( 2019-03-18 15:19:23 +0200 )éditer

En éditant la question initiale (lien éditer sous la question) il y a un trombone dans la barre d'outils qui permet le téléchargement de pj.

Par ailleurs, as-tu réussi à déterminer à quel moment l'espace est ajouté (lors de l'ouverture, de l'enregistrement...) ?

Image Gravatar de pierre-yves samynpierre-yves samyn ( 2019-03-18 16:37:25 +0200 )éditer

Merci beaucoup Pierre-Yves pour votre aide précieuse et votre solution. J'ai essayé en sauvant mon ficher sous Excel 2007-2019, après avoir modifié le lien, et c'est bon. Par contre avez vous une routine qui supprimerait ces erreurs de lien sur tout une feuille, au lieu de les reprendre un par un ce qui va être extrêmement fastidieux. surtout pour des fichiers avec beaucoup d'onglets...? Merci encore et très bonne journée

Image Gravatar de JakGillJakGill ( 2019-03-19 10:47:25 +0200 )éditer

@JakGill a écrit:

avez vous une routine qui supprimerait ces erreurs de lien ?

Voir l'ajout dans ma réponse...

Image Gravatar de pierre-yves samynpierre-yves samyn ( 2019-03-19 16:06:12 +0200 )éditer

1Réponse

0

répondue 2019-03-19 08:48:29 +0200

Image Gravatar de pierre-yves samyn

updated 2019-03-19 16:05:13 +0200

@JakGill

Merci pour la pièce jointe qui m'a permis de reproduire le bug sous windows avec la version Version: 6.2.1.2 (x64) Build ID: 7bcb35dc3024a62dea0caee87020152d1ee96e71

Je reproduis lors de l'enregistrement au format Excel 97-2003. Il ne se produit pas avec l'enregistrement au format Excel 2007-2019.

Il ne se produit pas non plus avec l'enregistrement au format ods...

Pourrais-tu créer le rapport de bug, je le confirmerais ?

[Ajout]

Il devrait être possible de rectifier les liens globalement via ÉditionRechercher & remplacer :

  • Rechercher: http.*
  • Remplacer par: =LIEN.HYPERTEXTE("&")
  • Cocher l'option "Expressions régulières".
  • Cocher éventuellement Sélection active seulement
  • Tout remplacer

En effet, le texte affiché est en principe toujours correct et c'est ce dernier qui sera utilisé par défaut par la fonction LIEN.HYPERTEXTE ; le libellé n'étant pas fourni, c'est l'url qui restera affiché...

Cordialement

Cordialement

éditer signaler supprimer permalien plus
S'identifier/S'inscrire pour répondre

Outils de question

1 suiveurs

Stats

Posée: 2019-03-13 18:47:31 +0200

Consultée: 30 fois

Mise à jour: Mar 19