Poser votre question
0

Recherche occurrence d'un terme (et sur plusieurs feuilles)

posée 2019-11-07 14:18:37 +0100

Bonjour,

Tout est dans le titre : j'ai des soucis avec NB.SI. Je ne comprends pas où est le problème... et je n'ai même pas encore étendu ma recherche à toutes les feuilles du document.

Le monstre est ici (formule sur la dernière feuille).

Au secours s'il-vous-plaît ! Cordialement, PopLyne

éditer requalifier signaler fermer fusionner supprimer

1Réponse

0

répondue 2019-11-07 15:45:21 +0100

Image Gravatar de pierre-yves samyn

Bonjour

Ta cellule D3 (qui est en fait le résultat d'une fusion de cellules) est au format date. Un simple Ctrl+M pour effacer le formatage permet de retrouver un affichage correct.

Certaines formules (somme, moyenne...) gèrent les références 3D. Par exemple =SOMME($Feuille1.A1:$Feuille3.A1) totalise les cellules A1 de toutes les feuilles comprises entre Feuille1 et Feuille3. Malheureusement pour toi NB.SI ne gère pas cela. Pour avoir le total dans la feuille Bilan il te faudra soit calculer dans chaque feuille puis totaliser dans bilan soit faire par exemple :

=NB.SI(1er_trimestre.A3:K33;B3)+NB.SI(2e_trimestre.A3:K33;B3)+NB.SI(3e_trimestre.A3:K33;B3)+NB.SI(4e_trimestre.A3:K33;B3)

Cordialement

éditer signaler supprimer permalien plus

Commentaires

Bonjour Pierre-Yves,

Merci pour ta réponse hyper rapide ! J'ai compris le problème du formatage des cellules (c'est l'inconvénient d'être obligée de travailler sur un tableur que l'on a pas créé : on doit dépister tous les formatages...) et ça fonctionne. Merci beaucoup !

Maintenant, dans ma feuille "Bilan" j'aimerais afficher le nombre d’occurrence des termes : - « Initiation » même lorsqu'il est suivi/collé à différents chiffres, - « Pause » même lorsqu'il est pas seul dans la cellule. J'ai tenté de comprendre mais par dépit j'ai tout essayé... les " " / les ' ' / les * * / et les .* .*
Arggggg...

Image Gravatar de PopLynePopLyne ( 2019-11-08 13:00:52 +0100 )éditer
S'identifier/S'inscrire pour répondre

Outils de question

1 suiveurs

Stats

Posée: 2019-11-07 14:18:37 +0100

Consultée: 9 fois

Mise à jour: Nov 07