Poser votre question
0

images rognées : deux rendus différents sur 2 PC malgré les mêmes réglages des options

posée 2020-02-12 11:25:12 +0100

Image Gravatar de Véro

bonjour, J'ai réalisé de très nombreux fichiers writer (odt) avec des copier/coller d'images que j'ai rognées. Je suis en train de changer d'ordinateur. Mais, bien que j'ai installé exactement la même version de LibreOffice, et que tous les réglages optionnels que je peux comparer soient identiques d'un ordi à l'autre, lorsque j'ouvre mes fichiers sur mon nouveau PC, les images rognées n'apparaissent pas avec le même cadrage, ce qui les rend inexploitables. J'ai beaucoup cherché sur les forums, mais si ce problème est parfois mentionné, la solution ne figure nulle part. Merci de votre aide. cordialement Véronique

éditer requalifier signaler fermer fusionner supprimer

2Réponses

0

répondue 2020-02-13 11:08:58 +0100

Image Gravatar de Véro

Merci de ta réponse. Effectivement, je procéderai désormais sans faire de rognage, ne serait-ce que pour gagner en poids des fichiers. Mais comme j'ai 4 ans de travail derrière moi... difficile de tout jeter !

Le fichier est copié sur le nouvel ordinateur. Quand il s'ouvre, il n'est pas en statut modifié (au sens où il n'apparaît pas d'étoile sur l'icône sauvegarder). Les images non rognées n'ont pas de problème.

Les détails techniques : PC ancien (la brouette) Lenovo G50 sous Windows 10 - 64 bits, processeur Intel Celeron N2840 @ 2.16 GHz et RAM 4 Go PC nouveau (voiture de course) : Windows 10 - 64 bits, processeur intel Core i5-7200 @2500 GHz RAM 12 Go même version de LibreOffice : 5.2.2 (pas de différence de comportement avec une version plus récente, anyway)

Le bug décrit en référence est presque exactement le même. Les différences : OpenGL n'est pas activé dans mon cas. Dans mon cas, le fichier est copié sur le disque du nouveau PC, et non ouvert sur un répertoire partagé. Enfin, dans mon cas, l'image est toujours rognée, mais le cadrage est différent, alors que pour le collègue, il semble que le rognage ne s'applique plus du tout, en tout cas le cadrage de l'image 2 est beaucoup plus large.

J'ai tenté de reproduire le bug à partir d'un fichier vierge sur le premier PC, en copiant/collant une image d'un fichier puis en la rognant, et enfin en ouvrant ce fichier sur le second PC. Étonnamment, le bug ne se reproduit pas. J'ai donc fait comme je fais d'habitude, en faisant un "imprEcran" pour capter une image dans un manuel, Ctrl-V pour insérer l'image entière dans mon fichier odt, puis rogner pour "enlever" tout ce que je ne veux pas voir. Et là, le bug se reproduit.

Quand je compare les propriétés de l'image rognée sur chaque PC, je vois des différences (onglet Rogner) : Echelle dans le PC d'origine : 47% 47% et sur le nouveau PC : 135% et 81% ; et l'image d'origine : PC d'origine : 36,14 cm x 20,32 cm et PC nouveau : 28,91 cm x 16,26 cm ; densité : PC d'origine 96 PPI et PC nouveau 120 PPI.

Comment faire pour que le PC nouveau interprète correctement la densité de l'image copiée à partir du presse-papier ? Telle est la question...

cordialement Véronique

éditer signaler supprimer permalien plus

Commentaires

Comment faire pour que le PC nouveau interprète correctement la densité de l'image copiée à partir du presse-papier ? Telle est la question...

LibreOffice doit enregistrer l'image collée et utilise pour cela le format png et la résolution d'écran (tu peux dézipper le document, consulter le "sous-dossier" Pictures et ouvrir l'image dans un logiciel cf xnview).

Comme je l'indiquais, la seule méthode sûre me semble être l'enregistrement (par toi) de l'image au format qui convient (en tenant compte de l'utilisation du document : impression, consultation écran...), avec en outre redimensionnement avant insertion dans Writer.

Désolé, pas d'autre "truc" sous la main...

Cordialement

Image Gravatar de pierre-yves samynpierre-yves samyn ( 2020-02-13 19:18:43 +0100 )éditer
0

répondue 2020-02-12 15:01:19 +0100

Image Gravatar de pierre-yves samyn

Bonjour

Je n'ai pas rencontré ce problème (il faut dire que je préfère retravailler les images avant de les incorporer...).

J'ai néanmoins cherché et trouvé ce problème rapporté dans notre gestionnaire de bugs. Il n'a pas été reproduit ni donc confirmé : fdo#126954

Les fichiers joints à ce bug montrent en effet une différence mais ils ne permettent que de constater, pas d'expliquer comment les valeurs de rognage ont été changées...

Ceci m'amène à deux questions :

  • lors de l'ouverture du document sur l'autre ordinateur le document devrait avoir en principe le statut "modifié" si c'est à l'ouverture que sont changées les valeurs de rognage ?
  • quel est le moyen de "transport" ? Enregistres-tu sur clé ou autre support amovible ou "en ligne" ? Serait-ce lors de l'enregistrement que sont changées les valeurs ?

Quoiqu'il en soit tu pourrais confirmer le rapport en donnant le maximum de précisions possibles (ta configuration, ton modus operandi).

Cordialement

éditer signaler supprimer permalien plus
S'identifier/S'inscrire pour répondre

Outils de question

1 suiveurs

Stats

Posée: 2020-02-12 11:25:12 +0100

Consultée: 14 fois

Mise à jour: Feb 13