Poser votre question
0

Peut-on automatiser une référence aux cellules d'une colonne dans une cellule sur deux d'une ligne ?

posée 2020-02-22 11:43:22 +0100

Image Gravatar de gZen0n

updated 2020-02-22 11:43:49 +0100

Je souhaiterais pouvoir utiliser les références relatives afin de pouvoir vérifier : D3=SI(B4>0;B4;0) , F3=SI(B5>0;B5;0) , H3=SI(B6>0;B6;0) etc... c-à-d, si COLONNE = COLONNE + 2 , LIGNE = LIGNE + 1. Est-ce possible sans macro ?

Merci.

éditer requalifier signaler fermer fusionner supprimer

1Réponse

2

répondue 2020-02-22 13:49:31 +0100

Image Gravatar de Pioulo

Bonjour, C'est un problème assez courant de vouloir se référer à des cellules de manière automatisée. Ici la difficulté vient du fait que les cellules appelantes sont non contiguës et sur une même ligne alors que les cellules appelées sont contiguës et sur une même colonne. Pour le caractère ligne/colonne, le couple de fonctions INDIRECT(ADRESSE()) est indiqué. Pour le caractère contiguë/non contiguë, une division combinée à la fonction ENT est une bonne approche. Ce qui donnerait en D3 :=SI(EST.PAIR(COLONNE());SI(INDIRECT(ADRESSE(ENT(COLONNE(A1)/2)+4;2))>0;INDIRECT(ADRESSE(ENT(COLONNE(A1)/2)+4;2));0);"") À recopier vers la droite autant de fois qu'il est nécessaire. Cordialement, Pioulo

éditer signaler supprimer permalien plus

Commentaires

Merci de votre réponse, j'ai réussi à regler mon probleme en ajoutant une ligne d'index et en utilisant la fonction DECALER.

EDIT : Et en me basant sur vos conseils, j'ai supprimé ma ligne d'index et utilisé COLONNE.

Image Gravatar de gZen0ngZen0n ( 2020-02-22 14:53:19 +0100 )éditer

@Pioulo très bonne solution, je "vote" pour... :)

@gZen0n je me permets d'ajouter ce conseil : si les colonnes E et G ne sont pas vides il est touefois possible de copier vers la droite la formule de @Pioulo en masquant ces colonnes avant la copie : soit en les masquant soit en les "groupant" (une colonne seule peut être "groupée") et en repliant le groupe.

Codialement

Image Gravatar de pierre-yves samynpierre-yves samyn ( 2020-02-22 16:27:14 +0100 )éditer

Super astuce merci beaucoup ! Cela étant dit, j'ai tout repris après avoir lu les références à INDIRECT et ADRESSE dans le wiki, et j'utilise donc une adaptation de la formule proposée par @Pioulo ; et suite à cela, je me suis dit que pour une question d'adaptabilité du tableau, je pouvais adapter ma formule en ajoutant une condition vérifier le modulo 2 de ma colonne et en cas de non-respect de ma condition, intégrant une référence vers une autre feuille, où je rentre mes données bruts. Je découvre à quel point les tableurs peuvent être puissant, c'est très intéressant.

Image Gravatar de gZen0ngZen0n ( 2020-02-22 17:42:41 +0100 )éditer
S'identifier/S'inscrire pour répondre

Outils de question

1 suiveurs

Stats

Posée: 2020-02-22 11:43:22 +0100

Consultée: 55 fois

Mise à jour: Feb 22 '20