Poser votre question
2

formule de tri des données

posée 2020-06-22 19:14:48 +0200

Image Gravatar de SamNali

Bonjour,

mon tableau comprend trois colonnes utiles : - la date - le montant - la nature

(c'est peut-être anecdotique mais 2 colonnes sont intercalées entre le montant et la nature)

Je cherche un moyen de trier dans un autre tableur les montants par date selon la nature. Voir le fichier joint, le but est de remplir automatiquement les cases G5 à K5, G9 à K9 et ainsi de suite...

J'espère avoir été assez clair, merci d'avance à la communauté pour votre aide précieuse !

C:\fakepath\report-dispatch.ods

éditer requalifier signaler fermer fusionner supprimer

3Réponses

2

répondue 2020-06-22 22:49:05 +0200

Image Gravatar de Pioulo

Bonsoir,

Pour ventiler des sommes, la fonction de base qu'on peut utiliser est SOMMEPROD(). Il s'agit de récupérer le mois dans le titre de chaque petit tableau (par CHERCHE et STXT) puis de lui donner un format de date (avec §) et enfin lui appliquer la fonction MOIS(). Pour que la formule s'adapte où qu'elle soit employée (par copier/coller), on peut appeler ce titre en utilisant les fonctions INDIRECT() et LIGNE(). Les plages de Date, Coût et Nature sont nommées (Insertion > Plages ou expressions nommées). Ce qui donne au final la formule (ici en G5) : =SOMMEPROD(MOIS(Date)=MOIS("01 "&STXT(INDIRECT("$G$"&LIGNE()-2);CHERCHE(" ";INDIRECT("$G$"&LIGNE()-2))+1;10)&" 2020");Nature=G4;Cout)

Voir le fichier. C:\fakepath\Ventilation_Piou.ods

Cordialement,

éditer signaler supprimer permalien plus

Commentaires

Bonjour,

j'ai oublié l'endroit où modifier les plages de données. Lorsque j'ouvre Insertion > Plages ou expressions nommées, une fenêtre s'affiche où il m'est impossible de modifier quoi que ce soit... J'aimerai changer le $B$30 en $B$100, comment faire ? Merci par avance pour votre réponse. Cordialement.

Image Gravatar de SamNaliSamNali ( 2020-12-06 11:29:31 +0200 )éditer
0

répondue 2020-08-30 18:42:08 +0200

Image Gravatar de mgl

Bonjour @Pioulo et @SamNali

Pour alléger l'excellente formule proposée par Pioulo, je suggérerais de modifier le contenu des cellules nommant les totaux du mois par les manip suivantes :

  • renseigner simplement 01/01/2020 pour Janvier, puis 01/02/2020 pour février, etc.

  • Modifier l'affichage de ces dates par Format > Cellule > Nombres et taper dans Description de format :

    "Total" MMMM

Les formules de recherche du mois peuvent alors se simplifier, par exemple, pour le premier mois, remplacer :

"01 "&STXT(INDIRECT("$G$"&LIGNE()-2);CHERCHE(" ";INDIRECT("$G$"&LIGNE()-2))+1;10)&" 2020"

par $G$3

Attention, cette méthode ne convient que pour une feuille qui ne contient que les données d'une seule année. Pour prendre en compte plusieurs années, il suffit de modifier l'affichage de dates en complétant ainsi la Description de format :

"Total" MMMM AAAA

et d'ajouter une 4e condition à la fonction SOMMEPROD, ainsi, pour le premier mois :

=SOMMEPROD(MOIS(Date)=MOIS($G$3);ANNEE(Date)=ANNEE($G$3);Nature=O4;Cout)

Cordialement, Michel

éditer signaler supprimer permalien plus
0

répondue 2020-06-22 23:00:47 +0200

Image Gravatar de SamNali

C'est énorme, franchement merci beaucoup Pioulo !!! (je n'ai malheureusement pas les point requis pour te gratifier d'une note méritée mais le coeur y est...) Bonne soirée !

éditer signaler supprimer permalien plus

Commentaires

Ah oui, j'ai oublié que j'avais rajouté un accent à FÉVRIER, car sinon la date 01 FEVRIER 2020 n'est pas reconnue comme telle par la fonction MOIS(). Cordialement,

Image Gravatar de PiouloPioulo ( 2020-06-23 02:00:35 +0200 )éditer

Bonjour @SamNali

Je ne sais pas si cela suffira à te permettre de "donner les points" mais

  • j'ai augmenté ton "karma"
  • j'ai "voté" pour la réponse de @Pioulo (en cliquant sur ˄)

Indépendamment des points tu peux marquer la réponse de @Pioulo comme acceptée en cliquant ✔ en haut à gauche de la réponse (ceci lui donnera points).

Cordialement

Image Gravatar de pierre-yves samynpierre-yves samyn ( 2020-06-23 08:26:25 +0200 )éditer

J'ai réussi à adapter la formule sur mon tableau, c'est impec ! Encore merci, ainsi qu'à PY, j'ai été checker le ✔. Bonne continuation à vous !

Image Gravatar de SamNaliSamNali ( 2020-06-23 17:07:34 +0200 )éditer
S'identifier/S'inscrire pour répondre

Outils de question

1 suiveurs

Stats

Posée: 2020-06-22 19:14:48 +0200

Consultée: 96 fois

Mise à jour: Aug 30 '20