Poser votre question
0

Calc - moyenne.si ou bdmoyenne ? [fermée]

posée 2020-08-18 11:24:37 +0100

Image Gravatar de JPC53

Bonjour, Quelle est la meilleure solution et où est l'erreur de syntaxe ?

A partir d'un fichier de données alimenté quotidiennement, j'ai besoin de faire des moyennes mensuelles automatiques : grand nombre de feuilles avec nombre d'enregistrement variable d'une colonne à l'autre et d'une feuille à l'autre. Les plages de données de la formule doit évoluer puisqu'il y a une ligne ajoutée par macro en tête de fichier à chaque enregistrement.

J'ai essayé la fonction "moyenne.si" en E2 pour le mois de mai, mais je ne trouve pas de syntaxe qui ne m'affiche pas l'erreur #DIV/0! en résultat. J'ai aussi essayé la fonction "bdmoyenne" en F2 pour le mois de juin, mais là aussi, je ne trouve pas la syntaxe qui ne m'affiche pas l'Err:504 en résultat.

Je mets un extrait du tableur : C:\fakepath\Moyenne mensuelle.ods

Merci d'avance.

éditer requalifier signaler réouvrir fusionner supprimer

Fermé pour la raison suivante la question est résolue, une bonne réponse a été acceptée par JPC53
date de clôture 2020-08-21 16:38:39.259203

3Réponses

1

répondue 2020-08-18 16:38:04 +0100

Image Gravatar de njhub

Bonjour JPC53,

Essayez avec les formules suivantes:

en E2 =SI(NB.SI($D6:$D58;E$1)<1;"";MOYENNE.SI($D6:$D58;E$1;$B6:$B58))à étendre vers la droite tant que nécessaire

en D6 =SI(ESTVIDE(A6);"";TEXTE(A6;"mmmm")) à étendre vers le bas tant que nécessaire

éditer signaler supprimer permalien plus
0

répondue 2020-08-18 19:16:56 +0100

Image Gravatar de Didier_Excel_libO

updated 2020-08-18 19:18:11 +0100

Bonjour, Ce qu'on voit affiché n'est pas forcément ce qu'il y a dans les cellules : En colonne D, il y a un format nombre... En ligne 1, il y a du texte ... Donc la recherche moyenne.si ne peut pas fonctionner. Modifications : Colonne D, la fle est << =SI(ESTVIDE(A6);"";TEXTE(A6;"mmmm"))>> Ligne 2 = =SIERREUR(MOYENNE.SI($D6:$D58;E$1;$B6:$B58);"")

Ci-joint le fichier CordialementC:\fakepath\MoyenneSi.ods

éditer signaler supprimer permalien plus
0

répondue 2020-08-18 18:08:27 +0100

Image Gravatar de JPC53

Merci njhub.

Ca fonctionne, même avec des références de cellule d'autres feuilles. Je vais chercher les données sur 12 feuilles et sur 9 colonnes chacune.

Je ne comprends pas pourquoi la fonction MOYENNE.SI ne fonctionne pas seule sur les lignes servies, en oubliant les lignes vides des plages. En ajoutant la fonction NB.SI, on exclut les lignes vides, mais ce n'est pas intuitif.

Pour D6, effectivement, je voyais que je me heurtais dans la formule en E1 au format date qui ne convenait pas , sans trouver à contourner la difficulté.

Merci beaucoup.

éditer signaler supprimer permalien plus

Outils de question

1 suiveurs

Stats

Posée: 2020-08-18 11:24:37 +0100

Consultée: 44 fois

Mise à jour: Aug 18 '20