Poser votre question
0

copier coller en supprimant les cellules vides (résultat "" d'une fonction)

posée 2020-11-29 16:52:23 +0100

Image Gravatar de ccs84

updated 2020-11-30 09:14:39 +0100

Bonjour à tous. Je n'arrive pas a trouver la formule magique afin de faire un copier d'une plage de données en enlevant les cellules vides, cellules résultant d'une fonction. Ci-joint un tableau plus explicatif. Si l'on peut passer du tableau 1 au tableau directement, je ne suis pas contre. Vous remerciant par avance de votre attention. Bien cordialement. ccs84C:\fakepath\Test suppression cellules vides.ods

éditer requalifier signaler fermer fusionner supprimer

Commentaires

Bonsoir,

Editez la description de votre question, avec le bouton éditez ci-dessus pour joindre le tableau annoncé.

Cordialement, Michel

Image Gravatar de mglmgl ( 2020-11-29 18:41:05 +0100 )éditer

2Réponses

1

répondue 2020-11-29 18:44:38 +0100

Image Gravatar de njhub

updated 2020-11-29 19:56:29 +0100

Ci-joint un tableau plus explicatif

Le lien est inactif

Bonjour css84

Pour enlever les doublons en BW9 à étendre vers la droite jusqu'en CI9

=SI(NB.SI($BG9:BG9;BH9)>0;"";BH9)

Pour ordonner les cellules non vides en BW8 à étendre vers la droite jusqu'en CI8

=SI(ESTNUM(BW9);COLONNE();"")

Pour récuperer les valeurs sans doublon et sans vide en CL9 à étendre vers la droite jusqu'en CX9

=SI(ESTERREUR(PETITE.VALEUR($BW$8:$CI$8;COLONNE()-89));"";INDIRECT(ADRESSE(9;PETITE.VALEUR($BW$8:$CI$8;COLONNE()-89));1))

C:\fakepath\ccs84_Test suppression cellules vides.ods

éditer signaler supprimer permalien plus

Commentaires

Bonjour @njhub

Merci pour ta proposition mais la pièce jointe ne la développe pas entièrement : elle s'arrête à une erreur 508 en CL8.

Après intégration de vos propositions ci-dessus dans le fichier fourni, le résultat est correct.

Cordialement, Michel

Image Gravatar de mglmgl ( 2020-12-19 16:08:09 +0100 )éditer
0

répondue 2020-11-30 08:56:12 +0100

Image Gravatar de ccs84

Bonjour à Tous. Je vous remercie pour votre aide. La solution de "djhub" fonctionne mais est très difficile à mettre en oeuvre dans un tableau déjà existant comportant des milliers de lignes (C'est ma faute, je n'avais pas signalé que le tableau comportait autant de données). Toutefois une autre solution m'a été proposée sur un autre forum. La voici si cela peut aider quelqu'un. =SIERREUR(INDEX($BW9:$CI9;1;PETITE.VALEUR(SI($BW9:$CI9="";"";COLONNE($A$1:$M$1));COLONNE(A$1)));"")

A valider en matricielle.

Vous remerciant encore, pour votre aide.

Cordialement CCS84

éditer signaler supprimer permalien plus

Commentaires

Bonjour @ccs84

Pourriez-vous préciser l'endroit où copier cette formule, SVP ? Je l'ai copié de CL9 à CW9 est n'ai obtenu qu'une répétition de douze 2, c'est à dire la plus petite de toutes les valeurs à filtrer.

Merci d'avance. Cordialement, Michel

Image Gravatar de mglmgl ( 2020-12-19 16:11:35 +0100 )éditer
S'identifier/S'inscrire pour répondre

Outils de question

1 suiveurs

Stats

Posée: 2020-11-29 16:52:23 +0100

Consultée: 60 fois

Mise à jour: Nov 30 '20