Fai la tua domanda
0

celle vuote, compatibilità tra versioni

chiesto il 2017-10-04 22:40:29 +0200

Buongiorno, ho LO su diverse macchine windows e mac. Sulle due ultime installazioni MAC (10.12.6 sierra) con LO 5.3.6.1 Calc gestisce le celle vuote in modo diverso ma non sempre. Ho un foglio usato da alcuni anni in cui la formula =media(A1:A30) si riferisce ad un intervallo in cui le formule delle celle =somma.se(xxx;xxx;xxx) inseriscono dei valori se li trovano oppure no. Nelle macchine precedenti (W10 e MAC) la formula =media(A1:A30) non considera le celle vuote e la media di 10,5,15 da 15. Nei due nuovi MAC invece considera le celle vuote come valori 0 e quindi da 1 [(10+5+15)/30 )].

Se faccio la media di un intervallo con e senza valori (imputati manualmente) le macchine si comportano nello stesso modo. Solo se le celle sono riempite dalla formula =somma.se(xxx;xxx;xxx) il comportamento è difforme

Ho letto che c'è stato un cambiamento di come considerare le celle vuote ma sulle macchine precedenti ho comunque la versione Still 5.2.6.2 .it ( help.libreoffice.org/Calc/Handling_of_Empty_Cells/it )

Ho provato a verificare in Strumenti/Opzioni/LibreOffice Calc/Formule/impostazioni dettagliate dei calcoli/ e i settaggi sono uguali in tutte le macchine.

Un grazie in anticipo a chi trova il tempo di darmi una risposta

modifica retag flag offensive close merge delete

1 Answer

0

risposto il 2017-10-05 08:58:47 +0200

Immagine gravatar per akurery

updated 2017-10-05 09:14:16 +0200

Ho provato ed anche in ufficio dove mi tocca usare Windows 10, 34 bit, LO versione 5.4.1.2, dà gli stessi risultati da te evidenziati.
Per ovviare ed ottenere un risultato corretto puoi comunque indicare alla formula SE di restituire una stringa vuota, anzichè uno 0, come in questo esempio.

=SE(D9<>0;D9;"")

Se però si va a puntare ad una cella vuota, mai toccata, effettivamente il problema sussiste.

modifica flag offensive delete link more

Commenti

@akurery intanto grazie del consiglio. ma quindi è un bug? (o un problema di Sierra?)

Immagine gravatar per margraziani margraziani ( 2017-10-07 18:56:49 +0200 )modifica

Ho fatto delle prove ed anche Excel si comporta così, non vorrei che per ragioni compatibilità ci si fosse allineati a questo modo di valutare le celle.

Immagine gravatar per akurery akurery ( 2017-10-09 12:28:07 +0200 )modifica
Login/Signup to Answer

Question Tools

1 follower

Stats

Chieste: 2017-10-04 22:40:29 +0200

Seen: 32 times

Last updated: Oct 05 '17