Fai la tua domanda
0

validazione dati

chiesto il 2018-05-26 02:55:40 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Ho una serie di celle in calc con validazione dati su una lista di nomi. E possibile escludere nella dropdown i nomi già scelti nelle precedenti celle? Esempio Lista nomi A B C D

Nella prima cella, inserisco B Vorrei, nella seconda cella, vedere soltanto A,C e D.

modifica retag flag offensive close merge delete

1 Answer

0

risposto il 2018-05-26 15:20:14 +0100

Immagine gravatar per akurery

updated 2018-05-26 15:22:03 +0100

Lo puoi fare in questo modo:
Nelle celle da validare (presumiamo A1:A4) imposta la funzione Validità non su Elenco, ma su Intervallo di celle e lascia selezionati i parametri mostra elenco di selezione e disponi in ordine crescente.
Come sorgente seleziona le celle in cui avrai l'elenco dei valori possibili: A, B, C e D, che diciamo stiano nelle celle C1:C4.
In queste celle anziché inserire direttamente i valori ci metti una formula con =SE(CONTA.SE($A$1:$A$4;"A");"";"A"), nella seconda riga ci metti B al posto di A e così via.
Unico inconveniente che nell'elenco a discesa, dopo che è già stato selezionato un valore, avrai sempre un valore vuoto all'inizio, causato dalle celle libere generate dalla funzione SE.

modifica flag offensive delete link more

Commenti

Grazie, evito così di immettere 2 volte lo stesso valore nelle celle C1:C4 e l'inconveniente del primo valore vuoto nell'elenco è minimo.

Immagine gravatar per nad nad ( 2018-05-27 03:27:17 +0100 )modifica
Login/Signup to Answer

Question Tools

1 follower

Stats

Chieste: 2018-05-26 02:55:40 +0100

Seen: 35 times

Last updated: May 26 '18