Fai la tua domanda
0

Somma.se con intervallo di fogli

chiesto il 2019-01-15 21:38:05 +0200

Immagine gravatar per ciocci

updated 2019-01-17 22:32:30 +0200

Ciao a tutti, ho un dubbio che non sono riuscito a risolvere, nonostante mille ricerche. Per esigenze di lavoro, ho bisogno di registrare le fatture dei miei clienti in un file excel, con una scheda (foglio) per ogni fattura, che riporta il nome del cliente e gli articoli venduti. In un foglio di riepilogo, avrei bisogno di visualizzare il resoconto degli acquisti, divisi per articolo, così da vedere la quantità di articoli venduti per ogni cliente. Una funzione, quindi, che sommi il valore di una determinata cella (uguale in tutti i fogli), se il nome del cliente è lo stesso. Sarebbe, in pratica, un somma.se, che sullo stesso foglio funziona, se applicato ad un intervallo di fogli, non funziona più. Come posso fare? Grazie mille in anticipo. CS

EDIT Ho allegato un file di esempioC:\fakepath\esempio somma intervalli.ods

modifica retag flag offensive close merge delete

Commenti

Ciao posta un file d'esempio senza dati sensibili, ma rispecchio la struttura del tuo file.

Immagine gravatar per gioh66 gioh66 ( 2019-01-15 23:09:16 +0200 )modifica

Inserito nel testo originale. Ho anche lasciato una delle mille formule che ho provato, ma che non funziona. Grazie in anticipo.

Immagine gravatar per ciocci ciocci ( 2019-01-17 22:33:26 +0200 )modifica

2 Answers

0

risposto il 2019-01-18 00:19:00 +0200

Immagine gravatar per akurery

updated 2019-01-18 00:21:35 +0200

In effetti SOMMA.SE su più fogli è ostico, ho cercato su altri siti ed ho trovato una soluzione con questa formula:

=MATR.SOMMA.PRODOTTO(SOMMA.SE(INDIRETTO($B$2:$I$2&".A4");$B$4;INDIRETTO($B$2:$I$2&".B7:B16")))

nelle celle da B2 a I2 è inserito un elenco dei nomi dei fogli.
Ti allego il file.
Non so se hai un motivo particolare per dover mettere i dati di ogni fattura su fogli separati. Personalmente preferirei metterli tutti in un'unica tabella e poi filtrare i dati con delle tabelle pivot: una per il riepilogo ed una per le varie fatture.
Anche qui allego un file di esempio.

C:\fakepath\matricesommaprodotto.ods
C:\fakepath\tabellepivot.ods

modifica flag offensive delete link more

Commenti

Funziona! Grazie mille. Sì, hai ragione per il fatto della tabella pivot, ma i fogli sono più complicati, qui ho semplificato per sottolineare solo la formula necessaria. Grazie ancora!

Immagine gravatar per ciocci ciocci ( 2019-01-18 10:36:50 +0200 )modifica
0

risposto il 2019-01-18 23:36:48 +0200

Immagine gravatar per gioh66

Salve ho provato la formula di akurery ma salvo qualche errore mio (possibile) non mi da i risultati esatti. Con questa invece ottengo i risultati voluti. In B5 da tirare a destra e in basso.

=MATR.SOMMA.PRODOTTO(INDIRETTO($B$2:$I$2&".B7:B16")*(INDIRETTO($B$2:$I$2&".A4")=B$4)*(INDIRETTO($B$2:$I$2&".A7:A16")=$A5))

C:\fakepath\riepilogo clienti.ods

modifica flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Chieste: 2019-01-15 21:38:05 +0200

Seen: 41 times

Last updated: Jan 18