Fai la tua domanda
1

conta.se su valori con operatori

chiesto il 2019-01-28 15:28:25 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Buongiorno a tutti e grazie in anticipo per le risposte. Veniamo subito al punto: In un foglio Libreoffice Calc devo contare, tramite la funzione CONTA.SE, le celle di un intervallo che contengono valori testuali di due caratteri, una lettera ed un numero o un simbolo come + o - (le celle in questione sono state impostate al formato testo) Nessun problema se devo contare le celle contenenti A- o A0, ma le celle che contengono A+ non vengono contate. La funzione CONTA.SE viene applicata ad una cella separata (es.: la cella S3) in questo modo: =CONTA.SE(B3:O3;S2), dove B3:O3 è l'intervallo di celle in cui verificare se è presente il valore A+ e S2 è la cella di confronto che contiene lo stesso valore (A+) anch'essa con formato testo. Spero che qualcuno possa aiutarmi

modifica retag flag offensive close merge delete

Commenti

Allega un file d'esempio

Immagine gravatar per gioh66 gioh66 ( 2019-01-29 20:54:33 +0200 )modifica

Quale versione hai di LibreOffice? Con la versione 6.0.6.2, su Windows 10, e le impostazioni che hai descritto, a me funziona tutto regolarmente.

Immagine gravatar per R.C. R.C. ( 2019-01-30 11:54:33 +0200 )modifica

2 Answers

1

risposto il 2019-01-31 16:28:53 +0200

Immagine gravatar per akurery

updated 2019-01-31 16:29:22 +0200

In Strumenti -> Opzioni -> LibreOffice Calc -> Calcola dovresti selezionare un'opzione che non permetta le espressioni regolari nelle formule, in pratica sceglipermetti caratteri jolly nelle formule.
Altrimenti il carattere + viene intepretato come parte di un espressione regolare.
In alternativa in S2 dovresti scrivere A\+, nelle espressioni regolari il carattere \ indica di interpretare il carattere successivo in modo letterale e non come comando dell'espressione.

modifica flag offensive delete link more
0

risposto il 2019-01-31 12:18:27 +0200

Immagine gravatar per Gippy73

Anche a me funziona correttamente: Versione: 6.0.4.2 su Linux 64bit

C:\fakepath\demo_ask_conta-se.ods

forse dovresti allegare il tuo file, con i dovuti omissis, eventualmente.

modifica flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Chieste: 2019-01-28 15:28:25 +0200

Seen: 38 times

Last updated: Jan 31