Fai la tua domanda
0

riportare dati da calendario in data odierna

chiesto il 2019-05-15 14:39:48 +0200

Immagine gravatar per dadani

Buongiorno, come da file allegato vorrei riportare in C23 i dati contenuti nella riga 3 , in D23 quelli in riga 4, in E23 quelli di riga5 e in F23 quelli di riga 6, naturalmente riferiti alla data odierna, mi farebbe piacere riuscire a riportare anche il colore dello sfondo. grazie danieleC:\fakepath\TEST.ods

modifica retag flag offensive close merge delete

2 Answers

0

risposto il 2019-05-20 16:57:38 +0200

Immagine gravatar per dadani

Scusa, ma finchè provo su una file nuovo di test non ho problemi a farlo funzionare, quando vado ad immettere le formule su un file già esistente, ottengo degli errori che non riesco a risolvere. nell' allegato al foglio AA vengono inseriti manualmente dei caratteri alfanumerici, che dovrebbero essere automaticamente aggiornati nel foglio BB dove H31 dovrebbe diventare il valore della riga 7 in AA riferito alla data odierna, sempre in BB -- H33 riga 8 -- K31 riga 9 -- K33 riga 10 -- N31 riga 11 -- N33 riga12 -- Q31 riga 13 -- Q33 riga 14 e cosi via per circa 500 righe, grazie ancora Daniele C:\fakepath\ ESPERIMENTO A 1.ods

modifica flag offensive delete link more

Commenti

Ciao, nel file che hai postato ci sono celle unite che non vanno d'accordo con le formule. Inoltre la matrice del CONFRONTA va riferita al foglio AA, per tanto devi scrivere la formula così

=INDICE(AA.$A$7:$ZA$800;RIF.COLONNA(A1);CONFRONTA(OGGI();AA.$A$6:$ZA$6;0))

Immagine gravatar per gioh66 gioh66 ( 2019-05-20 19:31:25 +0200 )modifica
0

risposto il 2019-05-15 18:55:44 +0200

Immagine gravatar per gioh66

Prova così: in C23 metti:

=INDICE($B$3:$H$8;RIF.COLONNA(A1);CONFRONTA(OGGI();$B$2:$H$2;0))

e trascina a destra. Per i colori potresti fare con la formattazione condizionale.

C:\fakepath\riportare dati per data.ods

modifica flag offensive delete link more

Commenti

Grazie, funziona alla grande, se volessi mettere la tabella di riepilogo su una altro foglio, come dovrei modificare la stringa? Daniele

Immagine gravatar per dadani dadani ( 2019-05-15 19:40:17 +0200 )modifica

Prego! Supponendo la tua tabella in Foglio2 e i dati in Foglio1, diventerebbe così

=INDICE($Foglio1.$B$3:$H$8;RIF.COLONNA(A1);CONFRONTA(OGGI();$Foglio1.$B$2:$H$2;0))

Immagine gravatar per gioh66 gioh66 ( 2019-05-15 22:13:20 +0200 )modifica

Grazie, appena ho tempo provo poi ti faccio sapere Daniele

Immagine gravatar per dadani dadani ( 2019-05-16 15:24:02 +0200 )modifica

funziona perfettamente grazie,una domanda a cosa si riferisce il valore (A1) nella stringa?

Immagine gravatar per dadani dadani ( 2019-05-16 16:40:26 +0200 )modifica

Se provi ad inserire la funzione RIF.COLONNA(A1) in una cella e trascinandola a destra vedrai che ti restituisce i valori 1, 2, 3, 4 ecc...cioè conta le colonne dinamicamente. Questo serve alla formula INDICE per indicare da quale riga prelevare i dati.

Immagine gravatar per gioh66 gioh66 ( 2019-05-16 20:25:44 +0200 )modifica

grazie mille molto chiaro Daniele

Immagine gravatar per dadani dadani ( 2019-05-17 12:24:28 +0200 )modifica

Scusa,ho fatto una risposta al post perchè come commento non riesco a mettere allegati Daniele

Immagine gravatar per dadani dadani ( 2019-05-20 16:57:26 +0200 )modifica
Login/Signup to Answer

Question Tools

1 follower

Stats

Chieste: 2019-05-15 14:39:48 +0200

Seen: 27 times

Last updated: 2 giorni fa