CALC - colorare i duplicati

chiesto il 2019-10-13 19:16:05 +0100

Immagine gravatar per Claudio R.

ciao, avrei la necessità di evidenziare i valori duplicati in un elenco; con la formattazione condizionale riesco ad evidenziare con uno stile delle celle quali sono, ma ciò che non riesco a fare (ammesso sia possibile) è colorare diversamente (anche in maniera casuale) i duplicati dello stesso tipo. (ES. A-A-C-B-D-B-E, vorrei per esempio lo sfondo di A giallo e quello di B verde.....)

Grazie dell'attenzione.

modifica retag flag offensive close merge delete

Commenti

In una cella, sfondi diversi?

Immagine gravatar per Schiavinatto Schiavinatto ( 2019-10-14 01:02:42 +0100 )modifica

quello credo che sia impossibile; ciò che chiedo, riprendendo l'esempio A-A-C-B-D-B-E, è che lo sfondo delle celle che contengo il valore A sia giallo e quelle che contengono B siano verdi. Spero di essere stato chiaro, grazie.

Immagine gravatar per Claudio R. Claudio R. ( 2019-10-14 08:33:39 +0100 )modifica
1

Buondì! Tu sai quali sono i valori duplicati? Ti metto un piccolo esempio dove con una formula trovo i valori duplicati, che poi uso per fare la formattazione condizionale. In J4 ho usato questa formula matrice (da confermare con ctrl+maiuscolo+invio) per sapere chi sono i duplicati

=SE.ERRORE(INDICE($A$1:$A$48;PICCOLO(SE(FREQUENZA(CONFRONTA($A$1:$A$48;$A$1:$A$48;0);RIF.RIGA($A$1:$A$48))>1;RIF.RIGA($A$1:$A$48));RIF.RIGA(A1)));"")

Con i dati ricavati ho fatto la FC sulla colonna A mettendo un colore diverso per ogni valore della colnna J.

https://www.dropbox.com/s/o9ec8gcw5xl...

Immagine gravatar per gioh66 gioh66 ( 2019-10-14 13:56:35 +0100 )modifica

grazie!!!! ....la studierò con attenzione :-)

Immagine gravatar per Claudio R. Claudio R. ( 2019-10-14 16:44:08 +0100 )modifica