Fai la tua domanda
0

Problema connettori

chiesto il 2020-05-15 08:41:28 +0200

Immagine gravatar per bgiordy

Ho uno strano problema con i connettori. Se, ad esempio, devo connettere un rettangolo in basso con uno in alto a sinistra, il connettore non ci arriva direttamente ma lo aggira a spirale antioraria fino a collegarsi dalla parte opposta; se poi a un rettangolo ne devo connettere due identici equidistanti, i connettori non sono uguali e c'è sempre una specie di scalino. Non se sono riuscito a spiegarmi, ma non è facile senza immagine. Praticamente, i connettori si dispongono in modo casuale, senza simmetria e logica.

Grazie a chi mi può consigliare

modifica retag flag offensive close merge delete

2 Answers

0

risposto il 2020-05-16 21:50:48 +0200

Immagine gravatar per akurery

updated 2020-05-17 11:38:03 +0200

I connettori si agganciano al punto centrale del lato del rettangolo, il giro che fa dipende da quale lato lo fai partire.
Per connettere un rettangolo che si trova in alto a sinistra rispetto a quello di partenza, partirei dal lato in alto, altrimenti farà il giro del rettangolo per arrivare all'altro punto al quale lo hai agganciato.
Se hai già tracciato il connettore, basta che lo selezioni e poi trascini il punto tondo al suo inizio verso il punto centrale di un altro lato al quale agganciarlo.
Credo di aver fatto anch'io un giro di parole un po' contorto, ma spero di essermi spiegato.

Per lo scalino invece è probabile che tu abbia allineato i rettangoli "ad occhio", prova a selezionarli entrambi e poi usare il comando Forma - Allinea - In alto o In basso, così anche i connettori che vanno verso lo stesso punto dovrebbero incontrarsi alla stessa altezza.

descrizione immagine

modifica flag offensive delete link more
0

risposto il 2020-05-17 09:23:51 +0200

Immagine gravatar per bgiordy

Grazie per la risposta. Il problema non è il lato da cui si fa partire il connettore ma la distanza tra i due oggetti: se, dopo aver connesso due rettangoli, faccio variare la distanza, il connettore non adegua la sua lunghezza ma fa delle strane capriole. Penso che sia uno dei tanti difetti del programma. Strano che altre persone non se ne siano accorte. Ho pubblicato in questa pagina http://www.gmpe.it/prova due esempi esplicativi.

Grazie ancora

modifica flag offensive delete link more

Commenti

Seleziona il connettore ed agisci sulle "maniglie" quadrate che appaiono. Così gli fai fare il giro che vuoi tu. Vedi l'immagine che ho allegato alla risposta precedente.

Immagine gravatar per akurery akurery ( 2020-05-17 11:38:20 +0200 )modifica

Quando non ci sono alternative uso le maniglie. Se però ho un grafico complesso con moltissimi riquadri, diventa seccante.Ho impiegato una giornata intera per aggiustare i collegamenti nel grafico che ho aggiunto sempre alla pagina http://www.gmpe.it/prova. Pensavo di sbagliare qualcosa e per questo ho chiesto, ma invece è il programma che si comporta in modo bizzarro.

Nella figura qui sopra, comunque, il giro del connettore è corretto, mentre nel mio esempio il collegamento lo prende dalla parte opposta.

grazie

Immagine gravatar per bgiordy bgiordy ( 2020-05-17 16:47:59 +0200 )modifica
Login/Signup to Answer

Question Tools

1 follower

Stats

Chieste: 2020-05-15 08:41:28 +0200

Seen: 34 times

Last updated: May 17