Fai la tua domanda

vhradice's profile - attività

2018-06-09 00:46:58 +0200 received badge  Domande famose (source)
2018-03-19 22:39:22 +0200 received badge  Domande famose (source)
2018-02-02 18:54:22 +0200 received badge  Domanda notevole (source)
2017-07-22 22:37:11 +0200 received badge  Domanda notevole (source)
2017-07-21 19:20:13 +0200 received badge  Domanda gettonata (source)
2017-07-21 18:01:21 +0200 ha modificato una domanda How do I list the controls in a dialog?

How do I list the controls in a dialog? I am debugging some freeware code as an addin to Calc and I am having 2 problems

2017-07-21 18:01:01 +0200 ha commentato una domanda How do I list the controls in a dialog?

Thank you @Lupp for reformatting the code.

2017-07-21 17:58:22 +0200 ha commentato una domanda How do I list the controls in a dialog?

Please excuse the formatting of the subroutine. I could not figure out how to separate the lines without having the cod

2017-07-21 17:46:05 +0200 ha posto una domanda How do I list the controls in a dialog?

How do I list the controls in a dialog? I am debugging some freeware code as an addin to Calc and I am having 2 problems

2016-07-21 22:46:04 +0200 received badge  Domanda gettonata (source)
2016-07-21 06:07:13 +0200 received badge  Entusiasta
2016-07-20 20:18:04 +0200 ha posto una domanda Problem with writer converting table to text

I am having a problem converting a table to text. The table has 4 columns and many rows. When I convert the table I will get 2 lines for each row. Line 1 is what I would like. Line 2 is like line 1 except the first 2 fields are empty and I get columns 3 and 4 repeated. How do I not get line 2 for each row? I can supply an example of the problem is desired.

Thank you

2015-12-05 21:27:04 +0200 received badge  Domande famose (source)
2015-11-28 13:28:08 +0200 received badge  Domanda notevole (source)
2015-11-27 22:46:01 +0200 received badge  Domanda gettonata (source)
2015-11-27 05:33:43 +0200 ha posto una domanda can I access a Base database with java

I currently have a small database that I created using Base. It is using the default dbms - HSQL 1.18. I would like to be able to access the database using Java to pull some data from it. To do so through Base would be very time consuming. I do have java installed: Operating environment:

OS - Fedora 21 - 64 bit
LibreOffice 5.0.0.5
Java java -version
openjdk version "1.8.0_65"
OpenJDK Runtime Environment (build 1.8.0_65-b17)
OpenJDK 64-Bit Server VM (build 25.65-b01, mixed mode)

Can I do it?
If so, is there some documentation that describes what I need in the java program to make the connection?
Thank you,

2015-11-14 15:06:35 +0200 received badge  Domande famose (source)
2015-07-08 01:55:48 +0200 received badge  Domande famose (source)
2015-05-13 08:49:18 +0200 received badge  Domande famose (source)
2015-05-09 07:23:37 +0200 ha risposto a una domanda How do I distribute my application?

That sounds like the best approach. I looked at the link and I am having a hard time finding information on how to package my code and dialogs as an extension. I would like a little help in locating that part of the documentation that shows how to package my stuff.

Thank you.

2015-05-03 14:57:02 +0200 received badge  Domanda notevole (source)
2015-05-03 13:13:11 +0200 received badge  Domanda gettonata (source)
2015-05-03 06:48:18 +0200 received badge  Domande famose (source)
2015-05-02 21:31:14 +0200 ha posto una domanda How do I distribute my application?

I have written an application for Calc that I would like to distribute. It consists of some dialogs and macros. I have located the appropriate files. I am having a problem trying to write the installation instructions so that the files can be copied/imported into Calc. Must they be imported into Calc or can I point Calc to where the directory where the files are located?

2015-04-14 03:20:40 +0200 received badge  Domanda notevole (source)
2015-04-09 13:15:25 +0200 received badge  Domanda gettonata (source)
2015-04-08 20:46:52 +0200 ha posto una domanda What happened to my toolbars?

I upgraded my system to Fedora 21 and Libreoffice was also upgraded to version 4.3.6.2 as part of the upgrade. When I tried to open and use an existing database, I got a lot of errors that didn't make any sense as to what was wrong. I tried to search for an answer but could not find one. I went to the LO web site and saw that version 4.4.2.2 was available as a download. I downloaded it and installed it. When I tried to open and create a new text document the toolbar icons are really messed up. image description

Here is a screenprint of the toolbar area. What is going on?

Thank you

p.s. Yes - that is what the toolbar looks like.

2014-12-18 01:42:43 +0200 received badge  Domanda notevole (source)
2014-12-16 11:57:12 +0200 received badge  Domanda gettonata (source)
2014-12-15 23:12:53 +0200 ha posto una domanda Where can I find a tutorial for writing Macros in Calc?

I am trying to write some macros to perform some simple tasks in Calc to initialize fields in a spreadsheet I use. I have purchased the e-book "Learn OpenOffice.org Spreadsheet Macro Programming". The book is dated 2006 and it looks like the current API is very different from the book. I am looking for help in how to create a dialog that displays labels and text fields so I can enter the data and the macro will put it in the proper cells for me. That book does not show how to save data that is entered in Text fields into spreadsheet cells.

Any help would be appreciated. Thanks in advance.

2014-12-14 18:43:35 +0200 received badge  Studente (source)
2014-12-14 18:00:41 +0200 received badge  Domande famose (source)
2014-08-18 14:11:19 +0200 received badge  Domande famose (source)
2014-01-15 21:01:52 +0200 received badge  Domanda notevole (source)
2014-01-15 03:19:10 +0200 received badge  Domanda gettonata (source)
2014-01-14 18:01:06 +0200 ha posto una domanda Empty files

I am seeing something and I don't know if it is a problem or something I have to live with.

In the ~/.config/libreoffice/4/user/backup directory, I have 3,000+ files with 0 bytes. I assume that this means the files are empty. There are other files there which are not empty. The non-empty ones appear to be backups of files I have worked on. The empty files all appear to be attempts to backup a Base database that I have created using the built in hsql engine. The file is stored on my computer. The time stamps on the files are unusual. There are 6 files with a time stamp of 15:58, 6 with 15:59, 6 with 16:00 and the pattern continues for the other 3,500 empty files.

Does any one else have the same situation? I have the save/backup time in the general options set to 15 minutes.

I have a listing of all of the files if anyone wants to see it.

Thank you, Vince Radice

2013-12-08 00:13:03 +0200 received badge  Domanda notevole (source)
2013-11-30 13:25:45 +0200 received badge  Domanda gettonata (source)
2013-11-05 16:44:03 +0200 ha posto una domanda Why is Base creating empty files in the backup directory?

I was going through my backup disk and found many (30,000+) empty files in the Libre office config backup directory. There were for version 3. I deleted them from the V3 directory. I just found the same situation in version 4. There are 25,967 empty files ending with .odb in the v4 backup directory. Between midnight and 10:10 AM today, 8,600 files were created. All were empty. I had the database open but there was no activity on it (I was sleeping during most of the time). It is an embedded data base using HSQL. I don't know how to check which version. I expect the basic level as I have not tried to update it. Why is Base creating these? Do I have any control over how often a backup is created? Why are they empty? All odb files created there are empty. Is a backup of my database being created automatically? If so, where is it being put? If not, can I turn on the autobackup facility?

2013-10-17 20:33:29 +0200 received badge  Domanda notevole (source)
2013-10-03 16:44:09 +0200 received badge  Domanda gettonata (source)
2013-09-18 05:13:21 +0200 ha posto una domanda LO 4.1.1.2 will not open database

I upgraded to 4.1.1.2 from 4.1.0 and now I cannot open a database that I had created under a prior release and used with 4.1.0. Base hangs if I double click on the data base. If I open Base and try to use an existing data base (the same one) Base tell me to connect to one on a server. Mine is an hsql stored on my pc. I want to report this now as I will be going back to 4.1.0 as I need access to the database. I have a pc that I use for testing and I will use that pc to test any suggestions and , hopefully, a solution.