質問する
0

Calcに入力した「--」がオートコレクト機能で「-」に変換されてしまう

質問日 2018-07-01 01:56:41 +0100

a.ist のGravatar画像

updated 2018-07-03 13:21:35 +0100

$ powertop --auto-tune とペーストしたのに、 $ powertop -auto-tune になってしまいました。

オートコレクト機能をOFFしたいです。

edit retag flag offensive close merge delete

2 Answer

1

回答日 2018-07-04 03:39:11 +0100

shingen のGravatar画像

updated 2018-07-06 13:41:29 +0100

自分の場合は、別の方法で解決しました。 自動スペルチェックでは、解決しませんでした。 質問者が例にあげている 文字、スペース、ハイフン、ハイフン が文字、スペース、ダッシュ(短い線が一本)に変換されるのは解決できません。

# powertop --auto-tune とペーストしたのに、 $ powertop -auto-tune (これは、文字、スペース--が、文字、スペースとダッシュに変換されたためです)

また、質問者が、主題に記されている「"--”が"-”に変換される」ことはオートコレクトでは元々ありません。「(文字--文字)の場合は、(文字、ダッシュ、文字)に変換される」

自分が解決した方法は、 メニュー→ツール→オートコレクトオプション →オートコレクトダイアログ→オプションタブを選択

□ダッシュに置換 のチェックを外す です。

LibureOffice6.05(win10)にて確認

ただし、v5.1.6.2(リナックスLubuntu16.04)では、 □置換リストを使う のチェックを外さないといけなかった。

参考文献 https://help.libreoffice.org/Common/O...

edit flag offensive delete link もっと

Comments

余計な発言だったかもしれません。本質を外していたようで、申し訳ありません。 自分が、以前から困っていたことで、この質問を見た機会に自身で調べなおしてみた結果を発言しました。

shingen のGravatar画像shingen ( 2018-07-07 02:52:45 +0100 )edit
0

回答日 2018-07-01 03:06:43 +0100

a.ist のGravatar画像

検索したら、メニューから「ツール」→ 「自動スペルチェック」のOffで、解決しました。

あるエンジニアから, Excel likeソフトには、非常にイライラしますとコメントしています。

edit flag offensive delete link もっと

Comments

こんにちは。良かったですね。

自分の使っているDebian GNU/Linux Sid上でターミナルからCalcにコピー・アンド・ペーストしてみましたが、ハイフンは二つとも保たれていて特に問題なく貼り付けられました。

環境を詳しく書いてもらうと、突っ込んで調べられると思います。

バージョン: 6.0.5.2

Build ID: 1:6.0.5-1

CPU threads: 4; OS:Linux 4.16; UI render: default; VCL: gtk2;

ロケール: ja-JP (ja_JP.UTF-8); Calc: group

nogajun のGravatar画像nogajun ( 2018-07-03 13:19:06 +0100 )edit
ログイン/サインアップして回答する

質問ツール

1 follower

Stats

Asked: 2018-07-01 01:56:41 +0100

Seen: 88 times

Last updated: Jul 06