質問する
0

Linux(x64)のCalcがCPU100%でフリーズしてしまう

質問日 2018-10-17 04:54:43 +0200

hachisuka のGravatar画像

updated 2018-12-30 03:06:46 +0200

nogajun のGravatar画像

私の環境でcalcで以下の手順を行うとsoffice.binがCPU100%となってメモリも食いつぶしてフリーズしてします。LibreOfficeはLinux_x64(deb)のバージョン6.1.2.1, OSはLubuntu16.04 64bitを使用しています。安定版の6.0.6でも再現されましたがWindowsでは再現されませんでした。

手順

  1. calcを起動
  2. View -> Freeze Cells -> Freeze First Row で1行目を固定
  3. キーボードから「=」を入力
  4. キーボードの「↓」を押しカーソルを1つ下のセルに移動
  5. CPUが100%となってメモリも食いつぶしてフリーズします。

よろしくお願いいたします。

edit retag flag offensive close merge delete

1 Answer

0

回答日 2018-10-17 06:47:48 +0200

nogajun のGravatar画像

こんにちは。Debian Sid(amd64)のDebian版(6.1.3RC1)、TDF版(6.1.2)、ナイトリービルド(6.2.0alpha0)で試してみました。

バージョン: 6.1.3.1
Build ID: 1:6.1.3~rc1-1
CPU threads: 4; OS:Linux 4.18; UI render: default; VCL: gtk3; 

バージョン: 6.1.2.1
Build ID: 65905a128db06ba48db947242809d14d3f9a93fe
CPU threads: 4; OS:Linux 4.18; UI render: default; VCL: kde4; 

バージョン: 6.2.0.0.alpha0+
Build ID: 1a3846b70d7bb34ad4ce17eef1196fe42d74e41c
CPU threads: 4; OS:Linux 4.18; UI render: default; VCL: kde4; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-10-01_17:51:08

試した方法は、アクティブセルをA1セルにおいたままメニューの[表示]→[セルの固定]→[最初の行を固定]を選択。そして「=」を入力してカーソルの「↓」を押しました。

結果は、通常通り使用できました。

お使いになられているLibreOfficeは、ディストリビューション版でしょうか? https://www.libreoffice.org/download/... からダウンロードしたパッケージで試すとどうなりますか? (TDF版debパッケージはディストリビューション版と共存できるので、そのままインストールしても大丈夫です)

edit flag offensive delete link もっと

Comments

ありがとうございます!試して頂けてうれしいです。LibreOfficeは https://www.libreoffice.org からダウンロードしたものなので同じものを使っているという事になりますね。

なんか良いヒントをもらったので、一度、別のPCでOSをクリーンインストールしてみて、その状態で再現されるのか?あたりから試してみたいと思います。

また追って報告させていただきます。

hachisuka のGravatar画像hachisuka ( 2018-10-17 14:53:13 +0200 )edit

Ubuntu16.04 64bitをクリーンインストールした時の報告です。今回はLubuntuではなくてUbuntuで試してみました。

LibreOfficeのサイトから6.1.2をダウンロードし sudo dpkg -i *.deb でインストール、 libreoffice6.1 --calc で起動。 手順を実行 → 再現されず。

sudo apt install $(check-check-language-support -l ja) で日本語環境をインストール、再起動。 手順を実行 → 再現されず。

System Settings → Language Support → Keyboard input method system を fcitx に変更、再起動。 手順を実行 → フリーズ!再現されました!

System Settings → Language Support → Keyboard input method system を IBus(又はnoneに変更)、再起動。 手順を実行 → 再現されず。

fcitx が原因???

hachisuka のGravatar画像hachisuka ( 2018-10-18 12:20:45 +0200 )edit

興味深い記事を発見。 https://listarchives.libreoffice.org/...

もしかしてと思い、試しに fcitxの状態で、 SAL_USE_VCLPLUGIN=gen libreoffice6.1 --calc で起動したところフリーズしませんでした。

hachisuka のGravatar画像hachisuka ( 2018-10-19 05:14:15 +0200 )edit

こちらの環境ですが_

LinuxMint Tera64 LibreOffice 6.1.3.2 Fcitx+Mozc

です。

漢字入力の状態で、F10で全角「=」を半角にし、↓キーを押すのですが、再現されません。 別なマシンで、Fcitx+Mozcでは動作しない基板があり、Ibus+Mozcでなければいけない機種がありました。

基板・・・というか、チップセットによるものだと思います。

と、なると、LibreOfficeの原因では無いのではありませんでしょうか。

整理すると

◯Ibus ✕Fcitx

のと

✕Ibus ◯Fcitx

のがありました。

漢字変換はMozcを使ってます。 Ibus+Anthyも使ってました。

今回は、Ibus+Mozcで良いのでは?

PullNan のGravatar画像PullNan ( 2018-11-28 07:18:37 +0200 )edit

再現方法がわかりました。

インプットメソッドにfcitxを使っていて、使用しているツールキットがgtk3のときにフリーズします。

再現方法

  1. fcitxの環境でSAL_USE_VCLPLUGIN=gtk3をセットしてLibreOfficeを起動します。

    $ SAL_USE_VCLPLUGIN=gtk3 /opt/libreofficedev6.2/program/soffice --calc

  2. A1セルで 表示→セルの固定→最初の行を固定を選ぶ

  3. = を入力

  4. キーを押す

これで、どのバージョンのLibreOfficeでもCPU 100%になります。

これは以前のバグが完全に直っていなかったということなのかな?

nogajun のGravatar画像nogajun ( 2018-12-01 08:05:17 +0200 )edit

試したいところではありますが、私の場合

SAL_USE_VCLPLUGIN=gtk3 /opt/libreofficedev6.1/program/soffice --calc

と、安定版を入れてます。再現されませんでした。 ともあれ、こう言った障害報告が大事だと思います。

ヘルプ(H)に「障害報告」があります。送られる事を進言します。

PullNan のGravatar画像PullNan ( 2018-12-03 03:35:41 +0200 )edit

はい。すでに送ってます。

nogajun のGravatar画像nogajun ( 2018-12-04 01:31:46 +0200 )edit
ログイン/サインアップして回答する

質問ツール

1 follower

Stats

Asked: 2018-10-17 04:54:43 +0200

Seen: 792 times

Last updated: Dec 01 '18