Stel uw vraag
0

SQL-opdracht werkt niet in MariaDB

gevraagd 2017-12-21 15:36:17 +0100

Jelle_ gravatar image

Op YouTube heeft TheFrugalComputerGuy mij enorm veel geleerd over Libreoffice Base. Bijna alles wat hij aangeeft klopt. Helaas loop ik nu toch tegen iets aan wat bij hem wel werk (video 60) en bij mij echt niet.

Wie kan mij vertellen wat er verkeerd is in deze SQL-opdracht?

afbeeldings-beschrijving

Mijn database staat op een Synology NAS met een MariaDB database. Wanneer ik direct in de database de query uitvoer krijg is de volgende melding:

afbeeldings-beschrijving

Helaas kan ik op het internet niets vinden over scheidingstekens tussen opdrachten.

bewerken retag markeer ongewenst sluiten samenvoegen verwijderen

2 Antwoorden

0

beantwoord 2017-12-21 17:35:05 +0100

floris v gravatar image

updated 2018-01-04 19:54:11 +0100

Waarschijnlijk moer een puntkomma aan het eind.

Dat werkte niet. Moet "Default" niet helemaal in hoofdletters? Zie http://www.hsqldb.org/doc/1.8/guide/c... helemaal onderaan.

bewerken markeer ongewenst verwijderen link meer

Commentaren

of na "datumaanmaak"

cornouws gravatar imagecornouws ( 2017-12-22 10:11:35 +0100 )bewerken

Mijn kennis van SQL is niet erg groot, ik twijfelde of SET een nieuwe opdracht is of een parameter. Als het een aparte opdracht is, moet er zeker een puntkomma voor.

floris v gravatar imagefloris v ( 2017-12-22 10:51:43 +0100 )bewerken

Bedankt dat je wilt meekijken. Ik heb je antwoord uitgeprobeerd, maar waar en hoeveel puntkomma's ik er ook in zet, ik blijf dezelfde melding krijgen. Jammer. Ik hoop dat je nog een idee hebt. Laat het dan zeker even weten.

Jelle_ gravatar imageJelle_ ( 2018-01-04 16:36:12 +0100 )bewerken
0

beantwoord 2018-02-04 23:23:39 +0100

rwestein gravatar image

updated 2018-02-04 23:36:54 +0100

Zojuist op een HSQLDB geprobeerd en de genoemde instructie werkt hier wel. Er moet dan iets in de syntax van MariaDB zitten wat afwijkt...

FF zitten zoeken en ik heb dit gevonden: ALTER TABLE <table_name> CHANGE COLUMN <column_name> <column_name> DATETIME NOT NULL DEFAULT CURRENT_TIMESTAMP;

bewerken markeer ongewenst verwijderen link meer
Login/Registreer om te beantwoorden

Hulpmiddelen Vragen

2 volgers

Statistieken

Gevraagd: 2017-12-21 15:36:17 +0100

Bekeken: 53 keer

Laatst bijgewertkt: Jan 04 '18