Stel uw vraag
0

geneste functie toepassen

gevraagd 2018-02-25 13:48:21 +0200

doffer gravatar image

updated 2018-02-25 21:27:46 +0200

cornouws gravatar image

Ik w1l een geneste functie binnen calc toepassen maar na de nodige uren van zoeken vraag ik om hulp. De volgende matrix wil ik omzetten naar een geneste functie

Waarde %

'< 1000 = 0%

'> 1.000 + 10%

'> 2.000 + 25%

'> 5.000 + 40%

'> 10.000 + 50%

'> 20.000 + 63%

'> 50.000 + 70%

Wat ik ook probeer is een foutcode 508 of 510.

Ik werk met Versie: 5.4.5.1 (x64), Locale: nl-NL (nl_NL); Calc: group

Alvast bedankt

(NB om de '>'-tekens zichtbaar te maken, er een ' voor gezet - CN)

bewerken retag markeer ongewenst sluiten samenvoegen verwijderen

1 Antwoord

0

beantwoord 2018-02-25 21:33:42 +0200

cornouws gravatar image

Dag Doffer,

Een deel van de formule is

=ALS(A1<1000;0*A1;ALS(A1>10000;0,5*A1;ALS(A1>5000;0,4*A1;ALS(A1>2000;0,25*A1;ALS(A1>1000;0,1*A1;"")))))

Helpt dat?

vr. groet - Cor

bewerken markeer ongewenst verwijderen link meer

Commentaren

Cor, bedankt. Reden van foutmelding is inderdaad verdwenen :-)

Maar er is wel een vervolg vraag gerezen. Bijna aan het einde van de formule, voor de afsluitende ronde haken, heb je een lege tekst string "" geplaatst, Waarom?

J☼han

PS Top je opmerking voor tekst weergave van groter dan teken

doffer gravatar imagedoffer ( 2018-02-26 10:16:14 +0200 )bewerken

Fijn dat het werkt, Johan.

Die lege tekenreeks "" zet ik uit gewoonte als laatste argument. Volgens mij werkt een 0, of leeg laten, vaak ook. Maar ik heb wel eens gevallen gehad waarbij een lege tekenreeks nodig was voor weergave of verwerking van een deelresultaat.

Dus speel er mee, en kijk wat wanneer werkt ;)

cornouws gravatar imagecornouws ( 2018-02-26 12:10:21 +0200 )bewerken

NB Enig idee dat er aanvankelijk mis was?

cornouws gravatar imagecornouws ( 2018-02-26 12:10:49 +0200 )bewerken
Login/Registreer om te beantwoorden

Hulpmiddelen Vragen

1 volger

Statistieken

Gevraagd: 2018-02-25 13:48:21 +0200

Bekeken: 23 keer

Laatst bijgewertkt: Feb 26 '18